Bug 246127 - rpm -Uvh hangs forever
rpm -Uvh hangs forever
Status: CLOSED DUPLICATE of bug 246044
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Paul Nasrat
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-28 14:13 EDT by Terje Røsten
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-28 15:39:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terje Røsten 2007-06-28 14:13:29 EDT
Description of problem:

Installed fresh rpm 4.4.2.1-0.2.rc1 with yum update, then on first rpm command
after the update I get:


$ rpm -Uvh  /usr/src/redhat/RPMS/i386/lshw-2.10-2.fc8.i386.rpm
/usr/src/redhat/RPMS/i386/lshw-gui-2.10-2.fc8.i386.rpm
Preparing...                ########################################### [100%]
   1:lshw                   ########################################### [50%]

and hangs forever, strace of the rpm process gives:


$ strace -p 7886
Process 7886 attached - interrupt to quit
futex(0xb7bab4ac, FUTEX_WAIT, 1, NULL


Trying to kill:

1 - Ctrl-C don't help
2 - kill <pid> dont help
3 - kill -HUP don't help
4 - kill -9 killed it.

Then did

$ rm -rf /var/lib/rpm/__db.00*

and now the rpm -Uvh works, some rpm -e/rpm -Uvh also works.
Comment 1 Paul Nasrat 2007-06-28 15:39:54 EDT
This is likely to be an issue fixed earlier today with freeing db iterators

*** This bug has been marked as a duplicate of 246044 ***

Note You need to log in before you can comment on or make changes to this bug.