Bug 246145 - HD-5500 card from pchdtv and SBLive (emu10k1) fight for sound index
HD-5500 card from pchdtv and SBLive (emu10k1) fight for sound index
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sndconfig (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-28 16:03 EDT by Dylan R. Semler
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 03:56:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -v output (5.50 KB, text/plain)
2007-06-28 16:03 EDT, Dylan R. Semler
no flags Details
dmesg output (22.17 KB, text/plain)
2007-06-28 16:05 EDT, Dylan R. Semler
no flags Details
scsconfig.log (41.80 KB, text/plain)
2007-08-15 15:36 EDT, Dylan R. Semler
no flags Details
scsrun.log (136 bytes, text/plain)
2007-08-15 15:38 EDT, Dylan R. Semler
no flags Details

  None (edit)
Description Dylan R. Semler 2007-06-28 16:03:25 EDT
This is my first attempt at bugzilla so let's see how it goes.

Description of problem:
I am running a system with an HD-5500 from pchdtv and an SBLive sound card. 
When booting the system normally, the only sound devices detected are the one
associated with the HD-5500 (Conexant CX8801 and CX88).  

I can get the SBLive card to work by editing /etc/modprobe.conf and changing the
lines 
options snd-card-0 index=0
options snd-emu10k1 index=0

to have index=1 instead of 0.  The result unfortunately has the HD-5500 as my
default sound device.  Since this card only has capture capabilities, none of my
sound works.  I can force the SBLive card to be the default sound by basically
breaking the HD-5500 module.  I place

options btcx_risc index=1 

in /etc/modprobe.conf above the snd-card-0 line and reboot.  What I believe is
happening is this module (associated with the pchdtv card) does not understand
this option so it fails to load (/dev/dvb devices are not created).  Then the
SBLive modules load fine and sound works.

Version-Release number of selected component (if applicable):
using kernel 2.6.21-1.3228.fc7

How reproducible:
Always

Steps to Reproduce:
1.  Install F7 with an HD-5500 card and SBLive sound card using the emu10k1 drivers
2.  Boot system
  
Actual results:
After booting system, Conexant CX8801 (Alsa mixer) and CX88 (OSS mixer) are the
only available sound devices.

Expected results:
SBLive sound devices have lowest index, one of which is the default sound
device.  HD-5500 sound devices load and are placed with higher indexes.

Additional info:
It should be said that I don't really know what I'm talking about.  My use of
the term "index" and "sound device" may be wildly inaccurate.

From what I can tell, the dvb card gets loaded first and its sound devices are
placed as indexes 0 and 1.  When the SBLive card loads later, the options in
/etc/modprobe.conf try to force its indexes to the same values.  When it can't
because the HD-5500 is already there, it fails to load.

This bug might be related to 243542--though they are experiencing no sound
whatsoever with SBLive cards (emu10k1).
Comment 1 Dylan R. Semler 2007-06-28 16:03:25 EDT
Created attachment 158155 [details]
lspci -v output
Comment 2 Dylan R. Semler 2007-06-28 16:05:25 EDT
Created attachment 158156 [details]
dmesg output
Comment 3 Martin Stransky 2007-08-15 11:42:01 EDT
Can you try to use the system-config-soundcard utility for setting it up? Just
run system-config-soundcard from terminal as root.
Comment 4 Dylan R. Semler 2007-08-15 15:34:31 EDT
On a normal system boot (broken sound) system-config-soundcard detects only the
SB Live card, not the HD-5500 (which may be what is desired).

On the sound test tab:
Testing of the sound fails
Under device settings, there are no PCM Devices to select.

On the settings tab:
Again, there is only one audio card listed in the default audio card drop-down.
 There are no PCM devices to choose from.


I will attach scsconfig.log and scsrun.log.

Comment 5 Dylan R. Semler 2007-08-15 15:36:46 EDT
Created attachment 161397 [details]
scsconfig.log
Comment 6 Dylan R. Semler 2007-08-15 15:38:31 EDT
Created attachment 161398 [details]
scsrun.log
Comment 7 Martin Stransky 2007-08-16 08:01:30 EDT
Yeah, you're right. This problem should be fixed in F8. Please remove these
lines from /etc/modprobe.conf:

alias snd-card-0 snd-emu10k1
#options btcx_risc index=1
options snd-card-0 index=0
options snd-emu10k1 index=0
#remove snd-emu10k1 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-emu10k1

reboot your box, run system-config-soundcard. All your cards should be detected
now. Select your default card and rewrite all config files (on the "System" page).
Comment 8 Dylan R. Semler 2007-08-16 19:11:56 EDT
Yup, that was the right way to go about fixing it.  Everything is working now. 
Thanks!

Note You need to log in before you can comment on or make changes to this bug.