Bug 246150 - Package Review: dynamips - Powerful Cisco IOS Emulator/Hypervisor
Package Review: dynamips - Powerful Cisco IOS Emulator/Hypervisor
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
: 510463 1071109 (view as bug list)
Depends On:
Blocks: FE-Legal 249929
  Show dependency treegraph
 
Reported: 2007-06-28 16:23 EDT by Nigel Jones
Modified: 2014-05-03 20:40 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 02:38:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nigel Jones 2007-06-28 16:23:28 EDT
Dynamips is a powerful Cisco IOS emulator with hypervisor, allowing you
to run several IOS images (in particular 3600 and 7200 series) as fully
functional routers.

rpmlint etc clean, I'm a bit worried about using Cisco IOS with emulator in the
description though.
Comment 1 Nigel Jones 2007-06-28 16:37:35 EDT
SRPM: http://dev.nigelj.com/SRPMS/dynamips-0.2.7-1.src.rpm
SPEC: http://dev.nigelj.com/SRPMS/dynamips.spec

I've just noticed 0.2.7 vs 1.2.7, I'll fix that tonight (opps).
Comment 2 Pierre-Yves 2007-07-31 17:37:21 EDT
Hi

>MUST: rpmlint must be run on every package. The output should be posted in the
review.
$ rpmlint ../SRPMS/dynamips-0.2.7-1.fc6.src.rpm
../RPMS/i386/dynamips-0.2.7-1.fc6.i386.rpm
../RPMS/i386/dynamips-debuginfo-0.2.7-1.fc6.i386.rpm
=> clean

>MUST: The package must be named according to the Package Naming Guidelines.
Ok

>MUST: The spec file name must match the base package %{name}, in the format
%{name}.spec unless your package has an exemption on  Package Naming Guidelines. 
Ok

>MUST: The package must meet the  Packaging Guidelines.
License Text => absent whereas the COPYING is present in the original tarball
(I think README can also be included)

>MUST: The package must be licensed with an open-source compatible license and
meet other legal requirements as defined in the legal section of Packaging
Guidelines.
Ok

>MUST: The License field in the package spec file must match the actual license.
Ok

>MUST: If (and only if) the source package includes the text of the license(s)
in its own file, then that file, containing the text of the license(s) for the
package must be included in %doc
No (see above)

>MUST: The spec file must be written in American English
Ok

>MUST: The spec file for the package MUST be legible. If the reviewer is unable
to read the spec file, it will be impossible to perform a review.
Ok

>MUST: The sources used to build the package must match the upstream source, as
provided in the spec URL.
Ok

>MUST: The package must successfully compile and build into binary rpms on at
least one supported architecture.
Built Ok on i386

>MUST: All build dependencies must be listed in BuildRequires
Ok

>MUST: The spec file MUST handle locales properly. 
There is no so
Ok

>MUST: Every binary RPM package which stores shared library files (not just
symlinks) in any of the dynamic linker's default paths, must call ldconfig in
%post and %postun. 
Ok

>MUST: If the package is designed to be relocatable, the packager must state
this fact in the request for review, along with the rationalization for
relocation of that specific package.
Ok

>MUST: A package must own all directories that it creates.
I would prefer a more detailled one [ie {%_mandir}/man1/ is not owned by the
software as it contains other files (that would lead to a confusion on rpm -qf I
think)]
%{_bindir}/%{name}
%{_bindir}/nvram_export   
%{_mandir}/man1/%{name}.1.gz
%{_mandir}/man1/nvram_export.1.gz
%{_mandir}/man7/hypervisor_mode.7.gz

>MUST: A package must not contain any duplicate files in the %files listing.
Ok

>MUST: Permissions on files must be set properly. Executables should be set with
executable permissions, for example. Every %files section must include a
%defattr(...) line.
Ok

>MUST: Each package must have a %clean section, which contains rm -rf
%{buildroot} (or $RPM_BUILD_ROOT).
Ok

>MUST: Each package must consistently use macros, as described in the macros
section of Packaging Guidelines. 
Ok

>MUST: The package must contain code, or permissable content. This is described
in detail in the code vs. content section of Packaging Guidelines. 
Ok

>MUST: Large documentation files should go in a -doc subpackage.
Ok

>MUST: If a package includes something as %doc, it must not affect the runtime
of the application. 
Ok

>MUST: Header files must be in a -devel package
Ok

>MUST: Static libraries must be in a -static package.
Ok

>MUST: Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig' (for
directory ownership and usability)
Ok

>MUST: If a package contains library files with a suffix (e.g. libfoo.so.1.1),
then library files that end in .so (without suffix) must go in a -devel package.
Ok

>MUST: In the vast majority of cases, devel packages must require the base
package using a fully versioned dependency: Requires: %{name} =
%{version}-%{release} 
Ok

>MUST: Packages must NOT contain any .la libtool archives, these should be
removed in the spec.
Ok

>MUST: Packages containing GUI applications must include a %{name}.desktop file,
and that file must be properly installed with desktop-file-install in the
%install section. 
Ok

>MUST: Packages must not own files or directories already owned by other packages.
This is why I would prefer a more detailed %files section

>MUST: At the beginning of %install, each package MUST run rm -rf %{buildroot}
(or $RPM_BUILD_ROOT)
Ok

>MUST: All filenames in rpm packages must be valid UTF-8.
Ok

I did not find any big issue with the SHOULD condition.
Regards,
P.Y.
Comment 3 Pierre-Yves 2007-07-31 18:15:12 EDT
I realize looking at the official website that I will not be able to test the
package.

I am sorry but I can not do the review for the two packages.

Sorry again
Regards,
P.Y.
Comment 4 Jason Tibbitts 2007-09-22 00:03:16 EDT
I have to wonder about this; it's not useful without Cisco firmware, which we
can't give out.  We can't even tell anyone where to get it, since it is only
available to Cisco customers.  So I'm not sure whether this package is
acceptable for Fedora.
Comment 5 Mike McGrath 2007-09-27 18:03:42 EDT
I've contacted some people to see if we can get Cisco to release the firmware 
or even a templated or dummy firmware that we can ship with the package.  Stay 
tuned for more info.
Comment 6 Ralf Ertzinger 2007-11-28 06:44:41 EST
Apart from the IOS files, the sources contain two binary files
(mips64_microcode, ppc32_microcode) which are somehow incorporated into the
emulator.

I do not know what these files contain or where they come from and what license
they are under.
Comment 7 Jason Tibbitts 2008-01-18 02:45:32 EST
I don't think there's much hope that this will be allowable in Fedora,
regardless of how cool it might be.  Any objection to closing this?
Comment 8 Nigel Jones 2008-06-03 02:38:22 EDT
About time I closed this, doesn't meet entry requirements (binary blobs, ios etc
etc) - closing.
Comment 9 Itamar Reis Peixoto 2009-07-09 08:30:59 EDT
*** Bug 510463 has been marked as a duplicate of this bug. ***
Comment 10 Christopher Meng 2014-05-03 20:40:15 EDT
*** Bug 1071109 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.