Bug 246159 - If Windows partition exists, offer to resize partition (as well as dual-boot)
If Windows partition exists, offer to resize partition (as well as dual-boot)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
http://www.pcworld.com/article/id,133...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-28 17:09 EDT by David A. Wheeler
Modified: 2008-01-16 17:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 15:50:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David A. Wheeler 2007-06-28 17:09:44 EDT
Description of problem:
As noted in PC World, "Most Linux newcomers have a Windows installation on their
drive already, usually in a partition that takes up the whole drive. The Fedora
installer, however, can choose only to ignore that partition or remove it,
whereas other distributions (including OpenSuse and, yes, Ubuntu) can shrink the
Windows partition and free up space for Linux, leaving you with a machine that
can boot into either OS. The Fedora installer has almost none of these smarts."

Some potential Linux users don't know if they're ready for the full plunge into
Linux use... the initial install is likely to be their first use, and they're
unlikely to be willing to completely commit to using something they haven't used
for a long time.  Making it possible to resize Windows and keep it will make it
easier to take the plunge gradually, resulting in more users.  Since this
functionality exists in other FLOSS installers, this shouldn't be hard to do.


Version-Release number of selected component (if applicable): Fedora 7.


How reproducible:  Start with a system that has a Windows partition and no free
space, and try to install Fedora.


Steps to Reproduce:
1. Have system with only Windows partition.
2. Boot any Fedora installer.
  
Actual results:
No help in resizing Windows partition to make room for Fedora.

Expected results:
Aid resize of Windows.

Additional info:
See Fedora 7 review here:
http://www.pcworld.com/article/id,133307-c,linux/article.html
Comment 1 David A. Wheeler 2007-06-28 17:12:00 EDT
FutureFeature request!  Oops, sorry, I forgot to include that in the report -
this is obviously a feature request, not a failure to work as intended. 
Anaconda may not be the right destination, but I wasn't sure where else to put it.


Comment 2 Andre Robatino 2007-07-03 12:51:07 EDT
  A caveat is that some Windows machines, for example Dells, come with a fairly
complex partitioning scheme.  My Dell desktop came with 4 primary partitions - a
utility partition, a main Windows partition, a Ghost partition, and a Restore
partition.  I ended up using GParted to delete the last two and shrink the main
Windows partition, and then reinstall from the Windows CD which I had spent an
extra $10 to obtain (which has the nice side effect of getting rid of the
crapware), before installing Fedora.
Comment 3 David A. Wheeler 2007-07-03 14:37:11 EDT
A start would be putting GParted on the install and live CDs, and then detecting
if a few common "simple" cases are true.  If it's complicated, at least GParted
can do it.
Comment 4 Chris Lumens 2008-01-16 15:50:56 EST
anaconda will have support for partition resizing (including Windows partitions)
in F9.  Thanks for your patience.  I encourage you to try F9 Alpha or any of the
other test releases if possible to help us make sure this stuff actually works.
Comment 5 David A. Wheeler 2008-01-16 17:28:00 EST
Great news!  I think that will mean that many more people will try out Fedora.


Note You need to log in before you can comment on or make changes to this bug.