Bug 246166 - autorelabel, reboot, no change. does not seem to cause software updater to fail
Summary: autorelabel, reboot, no change. does not seem to cause software updater to fail
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: rawhide
Hardware: athlon
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-28 22:10 UTC by Charlie Colins
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 14:16:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Charlie Colins 2007-06-28 22:10:03 UTC
Description of problem:
selinux is preventing /usr/bin/Xorg (xdm_xserver_t) "unix_read unix_write" to
(rpm_t)

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.3.0.0-10.fc8
selinux-policy-3.0.1-1.fc8

How reproducible:
happens every time software updater is run

Steps to Reproduce:
1.run software updater
2.
3.
  
Actual results:


Expected results:


Additional info:
avc: denied { unix_read, unix_write} for comm="X" egid=0 euid=0
exe="usr/bin/Xorg" exit=-13 fsgid=0 fsuid=0 gid=0 items=0 pid=2097
scontext=system_u:system_r:xdm_xserver t:s0-s0:c0.c1023 sgid=0
subj=system_u:system_r:xdm_xserver_t:s0-s0:c0.c1023 suid=0 tclass-shm
tcontext-system_u:system_r:rpm_t:s0 tty=tty7 uid=0

relable, reboot, same results.

Comment 1 Daniel Walsh 2007-07-02 00:37:07 UTC
I don't know what the software updater is?  Are you talking about yum update?

This looks like Xorg is trying to communicate with an X application that is
labeled rpm_t?  

Comment 2 Daniel Walsh 2007-07-02 00:49:57 UTC
Fixed in selinux-policy-3.0.1-4.fc8

Comment 3 Daniel Walsh 2007-08-22 14:16:15 UTC
Should be fixed in the current release



Note You need to log in before you can comment on or make changes to this bug.