Bug 246169 - Cannot start xen domains after FC6->F7 upgrade, using fc6 xen kernel: 2.6.20-1.2952-1.fc6xen
Cannot start xen domains after FC6->F7 upgrade, using fc6 xen kernel: 2.6.20-...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
7
All Linux
low Severity urgent
: ---
: ---
Assigned To: Rik van Riel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-28 18:28 EDT by Gerry Reno
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-28 18:36:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerry Reno 2007-06-28 18:28:06 EDT
Description of problem:


Version-Release number of selected component (if applicable):
3.1.0

How reproducible:
everytime

Steps to Reproduce:
1. upgrade FC6->F7
2. boot F7 using 2.6.20-1.2952.fc6xen kernel
3. xm create /etc/xen/xen0 -c
4. see error
  
Actual results:
Error: Unable to connect to xend. No such file or directory.  Is xend running?
And we make sure that xend is running - still errors.

Expected results:
no error - xen domain starts

Additional info:
We are booting the 2.6.20-1.2952.fc6xen kernel because the F7 xen kernel crashes
on our hardware.  see bug# 245627

Found this in the xen-debug.log:

Xend started at Thu Jun 28 14:49:56 2007.
domctl operation failed -- need to rebuild the user-space tool set?
sysctl operation failed -- need to rebuild the user-space tool set?
Exception starting xend: (13, 'Permission denied')
Exception in thread Thread-2:
Traceback (most recent call last):
  File "/usr/lib/python2.5/threading.py", line 460, in __bootstrap
    self.run()
  File "/usr/lib/python2.5/site-packages/xen/xend/XendMonitor.py", line 220, in run
    for domid, cputimes in self._get_cpu_stats().items():
  File "/usr/lib/python2.5/site-packages/xen/xend/XendMonitor.py", line 198, in
_get_cpu_stats
    for domain in self.xc.domain_getinfo():
Error: (13, 'Permission denied')


I've never seen these errors before under fc6.
Comment 1 Daniel Berrange 2007-06-28 18:36:17 EDT
You can't use a FC6  Xen kernel with F7 Xen userspace & vica-verca. They must be
matched. Either all FC6 based, or all F7 based. This is because Xen 3.0.3 in FC6
is *not* ABI compatible with Xen 3.1.0 in F7.

Either run all FC6, or all F7  - you can't mix & match at will.
Comment 2 Gerry Reno 2007-06-28 18:44:15 EDT
Which F7 packages do I need to replace to get this working?
Comment 3 Daniel Berrange 2007-06-28 18:47:36 EDT
At the very least the 'kernel-xen' and 'xen' RPMs must be matched. This may
affect dependancies - you'll have to resolve any issues that arise in that
department. 
Comment 4 Gerry Reno 2007-06-28 19:15:45 EDT
Is it possible to run xen 3.1.0 with the fc6 kernel by loading some kernel module?
Comment 5 Gerry Reno 2007-06-28 19:54:27 EDT
This is not going to be doable.  Xen package has a list of dependencies as long
as your arm.

So how did F7 use a 2.6.20 xen kernel (2925) that worked with xen 3.1.0?  
Can F7 be upgraded to use a newer 2.6.20 kernel (at least 2952) that would work
with xen 3.1.0?  This would temporarily solve our problem.

Comment 6 Gerry Reno 2007-06-28 19:55:45 EDT
The 2.6.20 kernel would have to use the old IDE drivers in our case and not the
new libata drivers.
Comment 7 Daniel Berrange 2007-06-28 21:29:40 EDT
It is quite simple - either use all FC6  RPMs, or use F7 RPMs. If you try to mix
& match RPMs between 2 distros you are own your own & we can't help.  

Much as we'd like Xen to be compatible between FC6 & F7, the upstream Xen
utterly fails to provide a stable ABI between userspace & hypervisor, so it
simply won't work.

Note You need to log in before you can comment on or make changes to this bug.