Bug 246171 - selinux prevents vmware server console from running
selinux prevents vmware server console from running
Status: CLOSED DUPLICATE of bug 652297
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
athlon Linux
low Severity high
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-28 18:38 EDT by Charlie Colins
Modified: 2011-08-11 16:14 EDT (History)
1 user (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 10:16:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlie Colins 2007-06-28 18:38:30 EDT
Description of problem:
selinux is preventing /lib/ld-2.6.so from making the program stack executable

Version-Release number of selected component (if applicable):
glibc-2.6-3
selinux-policy-3.0.1-1.fc8

How reproducible:
every time I try to run vmware server console

Steps to Reproduce:
1.
2.
3.
  
Actual results:
vmware console server fails to run

Expected results:
expect vmware console server to run

Additional info:
selinux alert mentions changing the EXECSTACK flag on a library and indicates
that stack memory should "never ever" be executable.  Not sure I understand all
of this, because the vmware console server package did run before.
Comment 1 Jakub Jelinek 2007-06-29 03:49:09 EDT
glibc isn't involved here at all.
If vmware requires executable stack, it needs to be labeled appropriately.
Comment 2 Daniel Walsh 2007-07-01 21:06:47 EDT
Allowing execstack and ewecmem for selinux-policy-3.0.1-4.fc8
Comment 3 Daniel Walsh 2007-08-22 10:16:47 EDT
Should be fixed in the current release
Comment 4 Charlie Brady 2011-08-10 12:00:30 EDT
I'm still seeing this with F14. Comment #2 doesn't include enough detail to determine what was done, and why it is not effective in F14 (the selinux alert concerns /lib/ld-2.13.so in F14). 

I guess this is a bug with vmware-server-console, and will never be fixed.
Comment 5 Daniel Walsh 2011-08-11 16:14:41 EDT
I am going to close as dup of another bug that explains how to look for execstack libraries.

*** This bug has been marked as a duplicate of bug 652297 ***

Note You need to log in before you can comment on or make changes to this bug.