Bug 246183 - mx4j: unowned directories
Summary: mx4j: unowned directories
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mx4j   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Yong Yang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: EasyFix
Depends On:
Blocks: F10Target
TreeView+ depends on / blocked
 
Reported: 2007-06-29 01:03 UTC by petrosyan
Modified: 2008-11-21 16:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 16:46:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixed mx4j.spec (16.02 KB, text/plain)
2008-10-24 08:08 UTC, Yong Yang
no flags Details

Description petrosyan 2007-06-29 01:03:18 UTC
Description of problem:
mx4j should own the following directories:
/usr/lib/gcj/mx4j/
and
/usr/share/java/mx4j/boa/
because its the only package in Fedora that ever uses them.

Version-Release number of selected component (if applicable):
mx4j-3.0.1-6jpp.4

How reproducible:
Always

Steps to Reproduce:
1. rpm -qf /usr/lib/gcj/mx4j/ /usr/share/java/mx4j/boa/
2. rpm -qf /usr/lib/gcj/mx4j/*
3. rpm -qf /usr/share/java/mx4j/boa/*
4. yum provides /usr/lib/gcj/mx4j
5. yum provides /usr/share/java/mx4j/boa
6. yum provides /usr/lib/gcj/mx4j/*
7. yum provides /usr/share/java/mx4j/boa/*

Comment 1 John Poelstra 2008-10-10 22:08:44 UTC
This bug has been triaged

Comment 2 Fernando Nasser 2008-10-20 14:11:33 UTC
Yong, as you have to rebuild mx4j because of the Vendor thing, you can as well fix this.  Chek the upstream version plese, and merge the fixes.

Comment 3 Yong Yang 2008-10-24 08:08:19 UTC
Created attachment 321377 [details]
fixed mx4j.spec

Comment 4 Yong Yang 2008-10-24 08:13:21 UTC
David, I have fixed this bug, and checked by using "mock -r fedora-rawhide-i386", new spec file is attached, please help to upload it to fedora cvs and build it, thanks.

FYI:
-bash-3.2$ rpm -qpl /var/lib/mock/fedora-rawhide-i386/result/mx4j-3.0.1-6jpp.5.i386.rpm | grep gcj
/usr/lib/gcj/mx4j
/usr/lib/gcj/mx4j/mx4j-3.0.1.jar.db
/usr/lib/gcj/mx4j/mx4j-3.0.1.jar.so
/usr/lib/gcj/mx4j/mx4j-remote-boa-3.0.1.jar.db
/usr/lib/gcj/mx4j/mx4j-remote-boa-3.0.1.jar.so
/usr/lib/gcj/mx4j/mx4j-tools-3.0.1.jar.db
/usr/lib/gcj/mx4j/mx4j-tools-3.0.1.jar.so


Note You need to log in before you can comment on or make changes to this bug.