Bug 246230 - Consider Requires: pinentry-gtk for claws-mail-plugins-pgp
Consider Requires: pinentry-gtk for claws-mail-plugins-pgp
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: claws-mail-plugins (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-29 08:58 EDT by Jakub Hrozek
Modified: 2007-12-09 05:28 EST (History)
1 user (show)

See Also:
Fixed In Version: claws-mail-2.10.0-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-09 05:28:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jakub Hrozek 2007-06-29 08:58:11 EDT
Description of problem:
If claws-mail-plugins-pgp is installed and pinetry-gtk not, an attempt to send 
GPG-signed mail results in a dialog box saying "Bad passphrase". Upon 
installing pinetry-gtk, everything works as expected for a GUI client - i.e. a 
GUI dialog pops up asking for a password.

What do you think about requiring pinentry-gtk? I know that it probably adds a 
little more bloat to carry, but the pros (works out-of-the-box) might 
outweight it..

Version-Release number of selected component (if applicable):
all in fedora's repos afaik

How reproducible:
always

Steps to Reproduce:
1. Install claws and claws-mail-plugins-pgp 
2. Send a gpg signed mail - bad passphrase dialog box
3. Install pinentry-gtk (or pinentry-qt if Qt suits you better)
4. Send a gpg signed mail - a dialog box asking for a passphrase pops now
  
Actual results:
Dialog about "Bad passphrase" when no passphrase was asked

Expected results:
Ask for a passphrase, in a GUI way since claws is a GUI client

Additional info:
This is not a traditional "this doesn't work" bug but more of a "what is your 
opinion?" tracker :-)
Comment 1 Andreas Bierfert 2007-07-03 05:23:38 EDT
Seems like a good idea to me. Will be in 2.10.0.
Comment 2 Jakub Hrozek 2007-07-03 07:54:37 EDT
Cool, thanks!
Comment 3 Fedora Update System 2007-07-05 15:14:37 EDT
claws-mail-2.10.0-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Rex Dieter 2007-07-16 14:51:11 EDT
Better perhaps would be
Requires(hint): pinentry-gui

pinentry-gui is satisfied by either pinentry-qt or pinentry-gtk (or any other
futuristic pinentry gui frontend).  (hint) for when/if rpm ever get the notion
of soft/optional dependencies (not supported currently). 
Comment 5 Fedora Update System 2007-07-17 12:46:02 EDT
claws-mail-2.10.0-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Andreas Bierfert 2007-07-18 03:01:16 EDT
Hm, I wonder if -gtk is not enough as claws itself is a gtk application but I
suppose people can argue about that. I will change it for 2.11 or if there are
more bugs in 2.10 ...

Note You need to log in before you can comment on or make changes to this bug.