Bug 246265 - Ignore illegal domain in DHCP host name
Ignore illegal domain in DHCP host name
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dnsmasq (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jima
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-29 13:54 EDT by H.J. Lu
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 11:10:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
A patch to ignore illegal domain in DHCP host name (631 bytes, patch)
2007-06-29 13:54 EDT, H.J. Lu
no flags Details | Diff

  None (edit)
Description H.J. Lu 2007-06-29 13:54:13 EDT
I am using a Windows notebook in office and home with DHCP. Its DHCP host
name is hlu-mobl.amr.corp.intel.com. At home, I got

Jun 29 10:37:10 video dnsmasq[6877]: Ignoring DHCP host name
hlu-mobl.amr.corp.intel.com because it has an illegal domain part

As the result, reverse name lookup won't work. This patch changes it
to

Jun 29 10:41:25 video dnsmasq[7274]: Ignoring domain amr.corp.intel.com in DHCP
host name hlu-mobl.amr.corp.intel.com

and I get

[root@video log]# nslookup  hlu-mobl
Server:         127.0.0.1
Address:        127.0.0.1#53

Name:   hlu-mobl.in.lucon.org
Address: 192.168.10.184

[root@video log]#
Comment 1 H.J. Lu 2007-06-29 13:54:13 EDT
Created attachment 158226 [details]
A patch to ignore illegal domain in DHCP host name
Comment 2 H.J. Lu 2007-06-29 13:55:12 EDT
BTW, this how dhcp-3.0.5-4.fc6 works.
Comment 3 Jima 2007-08-29 11:10:33 EDT
Whoops.  Sorry I never addressed this.  I passed this on to upstream (Simon
Kelley), and his response was:

"Looks perfectly sensible to me: the code in question has changed some in the    
development tree, but I've provided the same behaviour there."

Not being a programmer, I can't make heads or tails of the code, but it indeed
looks fairly different in 2.40.

This seems (to me) like a bit of a radical change for a distro to be making to a
package, so I'm closing this as UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.