Bug 246267 - -novtswitch doesn't seem to work
-novtswitch doesn't seem to work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-29 14:04 EDT by jmccann
Modified: 2015-01-14 18:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-06 18:50:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
partial fix (1.23 KB, text/plain)
2007-06-29 17:09 EDT, jmccann
no flags Details

  None (edit)
Description jmccann 2007-06-29 14:04:10 EDT
-novtswitch            don't immediately switch to new VT

sudo /usr/bin/Xorg :102 -novtswitch

Still immediately switches to new VT.

Or is there another way to make this work.  I'm testing some user switching
stuff and I'd like to start an Xorg server in the "background".  Thanks.
Comment 1 jmccann 2007-06-29 17:09:12 EDT
Created attachment 158265 [details]
partial fix

This seems to fix the bug in the initialization where the VT is activated when
it shouldn't be.  However, there is another bug somewhere that assumes that the
VT was switched to and corrupts the current VT... looking for it.
Comment 2 Ray Strode [halfline] 2007-06-29 17:21:44 EDT
yea I talked to ajax about this before and he said the switch didn't really
work, so it's at least not a surprise.
Comment 3 jmccann 2007-06-29 17:34:07 EDT
Seems to go awry at dix/main.c:785
    if (!(*pfnInit)(i, pScreen, argc, argv))
Comment 4 jmccann 2007-06-29 17:47:58 EDT
Occurs with nv, intel, and nvidia drivers.
Comment 5 Adam Jackson 2007-07-02 16:21:08 EDT
The deal is, the driver's init function expects that it has the hardware.  So
the only sense in which novtswitch is meaningful, is when you're starting the X
server on a card that the kernel is not using for the virtual terminal head.

You can't start an Xorg server "in the background", because many parts of
initialization can fail, and you can't know whether you'll succeed or not
without going ahead and touching the hardware.  The best you could do is a
deferred launch that just waits to start the new server until its VT is brought
foreground; but that's not actually going to hide much latency.
Comment 6 jmccann 2007-07-05 11:18:57 EDT
Ajax, thanks for the explaination.  So, yeah, it sounds like this approach won't
work.
Comment 7 Adam Jackson 2007-07-06 18:50:06 EDT
Closing as WONTFIX.  I think it's something that needs consideration upstream,
but we're not going to solve that problem here.

Note You need to log in before you can comment on or make changes to this bug.