Bug 246274 - Please branch/build rdiff-backup for EL-4 and EL-5
Please branch/build rdiff-backup for EL-4 and EL-5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rdiff-backup (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gavin Henry
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-29 14:48 EDT by Konstantin Ryabitsev
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 19:16:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Konstantin Ryabitsev 2007-06-29 14:48:57 EDT
Hi, guys:

Would you be willing to branch and build rdiff-backup for EPEL?
Comment 1 Kevin Fenzi 2007-07-03 16:28:07 EDT
I would be happy to. In fact I needed rdiff-backup on a centos box the other day
and thought I should branch it. 

Gavin: Do you have any interest in maintaining in EPEL? Or would you like me to? 
Or co-maintain it? 
Comment 2 Gavin Henry 2007-07-03 16:59:48 EDT
Hi,

Sure. I would need to get up to speed on the build tools etc. I think
co-maintain would be best to start and then see how we get on.

Thanks,

Gavin.
Comment 3 Kevin Fenzi 2007-07-03 17:16:03 EDT
Luckily EPEL uses plague and all the same infrastructure as FC-6 does currently,
so it's not hard to get up to speed. ;)

Package Change Request
======================
Package Name: rdiff-backup
New Branches: EL-4 EL-5
Updated EPEL Owners: ghenry@suretecsystems.com,kevin@tummy.com
Comment 4 Gavin Henry 2007-07-03 18:45:03 EDT
Cool. Keep us posted.
Comment 5 Kevin Fenzi 2007-07-03 21:51:03 EDT
branched. The EL-4 and EL-5 branches should be there now. 
Would you like to test and build them? or would you like me to do so?
Note that the scripts branch EL-4 from FC-3 and EL-5 from FC-6, so we may want
to update both of those. 
Comment 6 Gavin Henry 2007-07-04 03:19:11 EDT
You go ahead.

Gavin.
Comment 7 Kevin Fenzi 2007-07-16 16:24:39 EDT
I was waiting for pylibacl and pyxattr, which are in now. 

It looks like EL-5 just builds and works fine. 
Testing EL-4 now. I am going to update it to 1.0.5 as well, since rdiff-backup
wants all versions to be the same when communicating, and it would be nasty to
not be able to backup your EL-4 machines except to other EL-4 machines. 

Will probibly check in and push something later tonight. 
Comment 8 Kevin Fenzi 2007-07-16 19:16:17 EDT
ok. I have build 1.0.5 for both EL-4 and EL-5. In my testing here they look good. 
They should be in the next EPEL push. 
Closing this bug now, and if anyone spots any issues, feel free to open a new
bug against them. 
Comment 9 Konstantin Ryabitsev 2007-07-16 21:32:47 EDT
Awesome! Thanks, Kevin.

Note You need to log in before you can comment on or make changes to this bug.