Bug 246274 - Please branch/build rdiff-backup for EL-4 and EL-5
Summary: Please branch/build rdiff-backup for EL-4 and EL-5
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rdiff-backup (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Gavin Henry
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-29 18:48 UTC by Konstantin Ryabitsev
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 23:16:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora-cvs+


Attachments (Terms of Use)

Description Konstantin Ryabitsev 2007-06-29 18:48:57 UTC
Hi, guys:

Would you be willing to branch and build rdiff-backup for EPEL?

Comment 1 Kevin Fenzi 2007-07-03 20:28:07 UTC
I would be happy to. In fact I needed rdiff-backup on a centos box the other day
and thought I should branch it. 

Gavin: Do you have any interest in maintaining in EPEL? Or would you like me to? 
Or co-maintain it? 

Comment 2 Gavin Henry 2007-07-03 20:59:48 UTC
Hi,

Sure. I would need to get up to speed on the build tools etc. I think
co-maintain would be best to start and then see how we get on.

Thanks,

Gavin.

Comment 3 Kevin Fenzi 2007-07-03 21:16:03 UTC
Luckily EPEL uses plague and all the same infrastructure as FC-6 does currently,
so it's not hard to get up to speed. ;)

Package Change Request
======================
Package Name: rdiff-backup
New Branches: EL-4 EL-5
Updated EPEL Owners: ghenry@suretecsystems.com,kevin@tummy.com

Comment 4 Gavin Henry 2007-07-03 22:45:03 UTC
Cool. Keep us posted.

Comment 5 Kevin Fenzi 2007-07-04 01:51:03 UTC
branched. The EL-4 and EL-5 branches should be there now. 
Would you like to test and build them? or would you like me to do so?
Note that the scripts branch EL-4 from FC-3 and EL-5 from FC-6, so we may want
to update both of those. 

Comment 6 Gavin Henry 2007-07-04 07:19:11 UTC
You go ahead.

Gavin.

Comment 7 Kevin Fenzi 2007-07-16 20:24:39 UTC
I was waiting for pylibacl and pyxattr, which are in now. 

It looks like EL-5 just builds and works fine. 
Testing EL-4 now. I am going to update it to 1.0.5 as well, since rdiff-backup
wants all versions to be the same when communicating, and it would be nasty to
not be able to backup your EL-4 machines except to other EL-4 machines. 

Will probibly check in and push something later tonight. 

Comment 8 Kevin Fenzi 2007-07-16 23:16:17 UTC
ok. I have build 1.0.5 for both EL-4 and EL-5. In my testing here they look good. 
They should be in the next EPEL push. 
Closing this bug now, and if anyone spots any issues, feel free to open a new
bug against them. 

Comment 9 Konstantin Ryabitsev 2007-07-17 01:32:47 UTC
Awesome! Thanks, Kevin.


Note You need to log in before you can comment on or make changes to this bug.