Bug 246313 - glx crashes with vesa driver
glx crashes with vesa driver
Status: CLOSED DUPLICATE of bug 220629
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-29 19:53 EDT by Alexandre Oliva
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-02 16:24:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file at the time of the crash (45.99 KB, text/plain)
2007-07-02 04:42 EDT, Alexandre Oliva
no flags Details
config file used at the time of the crash (5.69 KB, text/plain)
2007-07-02 04:43 EDT, Alexandre Oliva
no flags Details
Similar crash, now with nv driver (45.16 KB, text/plain)
2007-07-08 23:23 EDT, Alexandre Oliva
no flags Details

  None (edit)
Description Alexandre Oliva 2007-06-29 19:53:09 EDT
Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x6d) [0x48b99d]
1: /lib64/libc.so.6 [0x343aa30620]
2:
/usr/lib64/xorg/modules/extensions//libGLcore.so(xmesa_check_and_update_buffer_size+0xc)
[0x2aaab16ce14c]
3: /usr/lib64/xorg/modules/extensions//libGLcore.so [0x2aaab16fe41d]
4: /usr/lib64/xorg/modules/extensions//libglx.so [0x2aaaab3cd73b]
5: /usr/bin/Xorg(compPositionWindow+0x62) [0x4bf7c2]
6: /usr/bin/Xorg(ResizeChildrenWinSize+0x17b) [0x43a78b]
7: /usr/bin/Xorg(ReparentWindow+0x1df) [0x43aa1f]
8: /usr/bin/Xorg(ProcReparentWindow+0xbc) [0x44b50c]
9: /usr/bin/Xorg(Dispatch+0x1db) [0x44ba9b]
10: /usr/bin/Xorg(main+0x45d) [0x43480d]
11: /lib64/libc.so.6(__libc_start_main+0xf4) [0x343aa1daa4]
12: /usr/bin/Xorg(FontFileCompleteXLFD+0x229) [0x433ad9]

Fatal server error:
Caught signal 11.  Server aborting


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.3.0.0-9.fc7
xorg-x11-drv-vesa-1.3.0-8.fc7

How reproducible:
Happens most often while using full-screen Firefox at 1024x768, but I can't
figure out whether there's any specific action that triggers it.
  
Additional info:
Commenting out the line:
        Load  "glx"
appears to work around the problem.

I've never run into this problem with the nv driver on the same notebook, but I
need the vesa driver to be able to switch between the internal display and the
external VGA output for presentations.

Fortunately I've never experienced one of these crashes while delivering a
presentation, which is when I switch to vesa ;-)
Comment 1 Matěj Cepl 2007-07-02 04:21:08 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Alexandre Oliva 2007-07-02 04:42:47 EDT
Created attachment 158324 [details]
log file at the time of the crash
Comment 3 Alexandre Oliva 2007-07-02 04:43:23 EDT
Created attachment 158325 [details]
config file used at the time of the crash
Comment 4 Alexandre Oliva 2007-07-02 04:47:42 EDT
Hi, Matej,

As you'll see, the config file is carried over from earlier releases of Fedora
(maybe even all the way back to Red Hat Linux), and it enables me to easily
switch between nv (that provides me with the 1280x800 native resolution of the
LCD) and vesa (that enables me to deliver presentations with the external video
output, at 1024x768, because the BIOS doesn't support 1280x800 in the VESA
resolution tables).

I suppose the fact that vesa is not a default configuration for this box, the
fully-auto-detected Xorg.0.log would be useless for you, so I'm skipping it.  If
you'd still like it, I'll be glad to power up the notebook and get the file  for
you.

Thanks,
Comment 5 Adam Jackson 2007-07-02 16:24:20 EDT

*** This bug has been marked as a duplicate of 220629 ***
Comment 6 Alexandre Oliva 2007-07-08 23:24:00 EDT
Created attachment 158741 [details]
Similar crash, now with nv driver

I'm not sure whether this extra info is going to be useful, which is why I post
it to this dupe rather than to the main bug.  Same config file as above, except
that this time the nv layout was the one in use.

Note You need to log in before you can comment on or make changes to this bug.