Bug 246318 - Doc in TeX/LaTeX source ?
Doc in TeX/LaTeX source ?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Paul Nasrat
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-30 02:40 EDT by VnPenguin
Modified: 2009-09-21 17:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-03 08:18:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description VnPenguin 2007-06-30 02:40:49 EDT
Description of problem:
In /usr/share/doc/rpm-4.4.2 of rpm-4.4.2-46.fc7 package, almost doc here are in
LaTeX/TeX source format !!!

Version-Release number of selected component (if applicable):

rpm-4.4.2-46.fc7

How reproducible:
Just less file and see :)

Steps to Reproduce:
1. cd /usr/share/doc/rpm-4.4.2
2. less FILE
3.
  
Actual results:
 Almost are LaTeX/TeX source !!!

Expected results:

Please ship ONLY plain text doc, no LaTeX/TeX source, no PDF, no HTML Please !!!

Additional info:
Comment 1 Joachim Frieben 2007-06-30 06:19:35 EDT
It's not time for an April's fool! I have the same package installed,
and it's all plain text, both by inspection as by executing the
"file" command:

"rpm -q rpm": rpm-4.4.2-46.fc7

BETA-GPG-KEY:      PGP armored data public key block
builddependencies: ASCII English text
buildroot:         ASCII English text
CHANGES:           ASCII English text
conditionalbuilds: ASCII English text
dependencies:      ASCII English text
format:            ASCII English text
GROUPS:            ASCII text
hregions:          ASCII English text
macros:            ASCII English text
multiplebuilds:    ASCII English text
queryformat:       ASCII English text
relocatable:       ASCII English text
rollbacks:         ASCII English text
RPM-GPG-KEY:       ASCII English text
RPM-PGP-KEY:       ASCII English text
signatures:        ASCII English text
spec:              ASCII English text
triggers:          ASCII English text
tsort:             ASCII English text
Comment 2 Mario Torre 2007-06-30 15:13:41 EDT
Hello!

The files contains some LaTex controls.
For examples, "triggers" contains:

/*! \page triggers Trigger scriptlets            [line 1]

[...]

\subsection triggers_example A Simple Example    [line 10]

[...]

\verbatim                                        [line 23]
        1) sendmail is installed
        2) vmail is installed
        3) sendmail is removed
        4) vmail is removed
\endverbatim

and so on.

The files are perfectly readable, though.
Comment 3 VnPenguin 2007-07-01 03:14:01 EDT
Yes, LaTeX/TeX sources are ... plain text too. So they are READABLE.
But I think this is definitively a bug of Packager ! because LaTeX is created
for compiling, NOT for reading as a document of RPM package.
Comment 4 Panu Matilainen 2007-07-03 08:18:14 EDT
The docs have some resemblance to LaTeX sources but they're nowhere near valid
LaTeX. Turning them into valid LaTeX would of course be possible, but that'd
reduce the plain-text readability quite a bit, and as the current set of docs
are just assorted bits about this and that, forming a "real document" out of
them doesn't make much sense.

Note You need to log in before you can comment on or make changes to this bug.