Bug 246321 - fontconfig spec or Makefiles are lacking?
Summary: fontconfig spec or Makefiles are lacking?
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-30 08:07 UTC by Michal Jaegermann
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-26 01:18:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2007-06-30 08:07:14 UTC
Description of problem:

I tried to rebuild fontconfig-2.4.2-3.fc7.src.rpm (with some
debug changes).  There were no complaints about missing
BuildRequires but in a compilation I got:

....
docbook2txt local-fontconfig-user.sgml
Using catalogs: /etc/sgml/sgml-docbook-3.1-1.0-30.1.cat
Using stylesheet: /usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl#html
Working on:  (some data in a local directory here)
jade:/usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl:1:73:W: cannot
generate system identifier for public text "-//James Clark//DTD DSSSL Style
Sheet//EN"
jade:/usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl:5:95:W: cannot
generate system identifier for public text "-//Norman Walsh//DOCUMENT DocBook
HTML Stylesheet//EN"
jade:/usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl:11:0:E: reference to
entity "STYLE-SHEET" for which no system identifier could be generated
.....

and so on by many more lines.

Investigating that was not a goal here (I tried again to understand
bug 210718) so I just skipped all html in install and in specs and
build what was needed but something is not listed in BuildRequires?

Version-Release number of selected component (if applicable):
fontconfig-2.4.2-3.fc7

Comment 1 Behdad Esfahbod 2007-10-26 01:18:27 UTC
Means, docbook stylesheets are not installed.  There's a reason for those
BuildRequires...

I made it not rebuild docs btw, so it should be fixed anyway.


Note You need to log in before you can comment on or make changes to this bug.