Bug 246323 - While indexing, beagle daemon crashes
While indexing, beagle daemon crashes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Alexander Larsson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-30 04:42 EDT by sangu
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.2.18-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 02:11:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 452494 None None None Never

  None (edit)
Description sangu 2007-06-30 04:42:32 EDT
Description of problem:
$ beagled --fg --debug

***MEMORY-WARNING***: /usr/lib/beagle/BeagleDaemon.exe[4560]: GSlice:
g_thread_init() must be called before all other GLib functions; memory
corruption due to late invocation of g_thread_init() has been detected; this
program is likely to crash, leak or unexpectedly abort soon...
Always: Starting Beagle Daemon (version 0.2.17)
Always: Running on Mono 1.2.4
Always: Using sqlite version 3
Always: Command Line: /usr/lib/beagle/BeagleDaemon.exe --fg --debug
Warn: Extended attributes are not supported on this filesystem.  Performance
will suffer as a result.
Debug: Established a connection to the X server
Debug: Reniced process to 7
Debug: Loading Beagle.Util.Conf+IndexingConfig from indexing.xml
Debug: Loading Beagle.Util.Conf+DaemonConfig from daemon.xml
Debug: Loading Beagle.Util.Conf+SearchingConfig from searching.xml
Debug: Starting main loop
Debug: Beginning main loop
Debug: Starting messaging server
Debug: Starting QueryDriver
Debug: Found index helper at /usr/lib/beagle/beagled-index-helper
Debug: Found 2 backends in /usr/lib/beagle/Backends/EvolutionBackends.dll
Debug: KMail folders not found. Will keep trying 
Debug: Starting Inotify FSQ file event backend
Debug: KonqCacheDir: /var/tmp/kdecache-sangu/http
Debug: Found 16 backends in /usr/lib/beagle/BeagleDaemonLib.dll
Debug: Reading mapping from filters
Debug: Loading system static indexes.
Debug: Version mismatch in /var/cache/beagle/indexes/applications
Debug: Index has version 13.0, expected 17.-1
Warn: Unable to create read-only index (likely due to index version mismatch):
/var/cache/beagle/indexes/applications
Debug: Version mismatch in /var/cache/beagle/indexes/documentation
Debug: Index has version 13.0, expected 17.-1
Warn: Unable to create read-only index (likely due to index version mismatch):
/var/cache/beagle/indexes/documentation
Debug: Found 0 system-wide indexes.
Debug: Loading user-configured static indexes.
Debug: Found 0 user-configured static indexes..
Debug: Waiting 60 seconds before starting queryables
Debug: Starting Scheduler thread
Debug: Starting Inotify threads
Debug: Daemon initialization finished after .64s
Debug: Memory usage: VmSize=40.8 MB, VmRSS=16.6 MB,  GC.GetTotalMemory=1474560
Debug: Starting queryables
Debug: Starting backend: 'EvolutionMail'
Debug: Starting backend: 'EvolutionDataServer'
Debug: Starting backend: 'KMail'
Debug: Starting backend: 'Files'
Debug: Starting KMail backend
Debug: Adding root: /home/sangu
Debug: KMail directories (local mail) /home/sangu/.kde/share/apps/kmail/dimap
not found, will repoll.
Debug: Starting Evolution mail backend
Debug: Starting mail crawl
Debug: Will index mbox /home/sangu/.evolution/mail/local/Inbox
Debug: Opening mbox Inbox
Debug: Will index mbox /home/sangu/.evolution/mail/local/Drafts
Debug: Will index mbox /home/sangu/.evolution/mail/local/Sent
Debug: Will index mbox /home/sangu/.evolution/mail/local/Outbox
Debug: Will index mbox /home/sangu/.evolution/mail/local/Inbox.sbd/gmail
Debug: Will index mbox /home/sangu/.evolution/mail/local/Inbox.sbd/홈쇼핑
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/홈쇼핑.sbd/dell
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/홈쇼핑.sbd/KT청구서
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/hellocity.sbd/FedoraI18n
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/hellocity.sbd/FedoraConfig
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/hellocity.sbd/FreedesktopBugzilla
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/hellocity.sbd/fedora-trans-list
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/hellocity.sbd/RedHatBugzilla
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/hellocity.sbd/FedoraTransKo
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/hellocity.sbd/FedoraSelinux
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/hellocity.sbd/GnomeKrHacker
DebugDebugDebug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/FedoraArt
: Inbox: Finished indexing 0 messages
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/cairo
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/gtk
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/help-gnu-emacs
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/emacs-pretest-bug
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/emacs-unicode
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/fedora-kernel-list
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/Fedora
Debug: Inbox: indexed 0 messages
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/xorg
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/EvolutionHackers
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/dbus
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/fedora-extras
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/Compiz
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/gtk-app-devel
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/OpenOfficeIssueTracker
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/gmail.sbd/HAL
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/kornet.sbd/GnomeBugzilla
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/kornet.sbd/KernelBug
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/kornet.sbd/shrike-list
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/kornet.sbd/fedora-devel-list
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/kornet.sbd/KT 소식지
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/kornet.sbd/fedora-tools-list
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/kornet.sbd/fedora-test-list
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/kornet.sbd/emacs-devel
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/kornet.sbd/IBM developerWorks
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/kornet.sbd/XimianBugzilla
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/yahoo.sbd/devel-announce-list
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/yahoo.sbd/nautilus-list
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/yahoo.sbd/desktop-devel-list
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/yahoo.sbd/HangulHacker
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/yahoo.sbd/fedora-desktop-list
Debug: Will index mbox
/home/sangu/.evolution/mail/local/Inbox.sbd/yahoo.sbd/gtk-devel-list
Debug: Mail crawl finished
Debug: Evolution mail driver worker thread done in .32s
Debug: Loaded 35496 records from
/home/sangu/.beagle/Indexes/FileSystemIndex/FileAttributesStore.db in 0.773s
Debug: Done starting FileSystemQueryable
Debug: Starting backend: 'GaimLog'
Debug: Starting Gaim log backend
Debug: Setting up inotify watches on gaim log directories
Debug: Gaim log backend worker thread done in .03s
Debug: Starting backend: 'IndexingService'
Debug: Setting up an initial crawl of the IndexingService directory
Debug: Starting backend: 'Tomboy'
Debug: Tomboy backend started
Debug: Starting backend: 'Labyrinth'
Debug: Starting backend: 'Blam'
Debug: Starting backend: 'Liferea'
Debug: Starting backend: 'Akregator'
Debug: Starting backend: 'KonquerorHistory'
Debug: Starting backend: 'KonqBookmark'
Debug: Starting backend: 'KNotes'
Debug: Starting backend: 'KOrganizer'
Debug: Starting backend: 'KAddressBook'
Debug: Starting backend: 'Kopete'
Debug: Starting backend: 'Konversation'

** (/usr/lib/beagle/BeagleDaemon.exe:4560): WARNING **: Missing method
Evolution.CalUtil::FreeGlueCompGLibSList(intptr) in assembly
/usr/lib/mono/gac/evolution-sharp/2.0.0.0__457eed85bd9370df/evolution-sharp.dll,
referenced in assembly /usr/lib/beagle/Backends/EvolutionBackends.dll
Error: Unhandled exception thrown.  Exiting immediately.
System.MissingMethodException: Method not found:
'Evolution.CalUtil.FreeGlueCompGLibSList'.
in (unmanaged) 0x812e8f5
at <>c__CompilerGenerated1.<>c__AnonymousMethod2 () <0x00015>
at (wrapper delegate-invoke) System.MulticastDelegate.invoke_bool () <0x0002e>
at IdleProxy.Handler () <0x0002a>
at (wrapper native-to-managed) IdleProxy.Handler () <0x00047>
in (unmanaged) 0x17d520
at (wrapper managed-to-native) GLib.MainLoop.g_main_loop_run (intptr) <0x00004>
at GLib.MainLoop.Run () <0x0000d>
at Beagle.Daemon.BeagleDaemon.DoMain (string[]) <0x00b7b>
at Beagle.Daemon.BeagleDaemon.Main (string[]) <0x00014>


Version-Release number of selected component (if applicable):
0.2.17-1.fc8

How reproducible:
always

Steps to Reproduce:
1. $ beagled

***MEMORY-WARNING***: /usr/lib/beagle/BeagleDaemon.exe[4802]: GSlice:
g_thread_init() must be called before all other GLib functions; memory
corruption due to late invocation of g_thread_init() has been detected; this
program is likely to crash, leak or unexpectedly abort soon...

2.
3.
  
Actual results:


Expected results:


Additional info:
glib2-2.13.6-1.fc8
gtk2-2.11.4-1.fc8
mono-core-1.2.4-1.fc8
gtk-sharp2-2.10.0-4.fc7
GNOME Desktop 2.19.4
OS Fedora development( rawhide 20070629 )

Note You need to log in before you can comment on or make changes to this bug.