Bug 246328 - GTK+ translations for az stored in unsupported charset
GTK+ translations for az stored in unsupported charset
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gtk+ (Show other bugs)
6
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-30 08:24 EDT by Dwayne Bailey
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 12:32:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 480586 None None None Never

  None (edit)
Description Dwayne Bailey 2007-06-30 08:24:15 EDT
Description of problem:
/usr/share/locale/az/LC_MESSAGES/gtk+.mo is encoded in ISO-8859-9E which is not
available on Fedora.

Version-Release number of selected component (if applicable):
gtk+-1.2.10-55.fc6

How reproducible:
msgunfmt /usr/share/locale/az/LC_MESSAGES/gtk+.mo 

Steps to Reproduce:
1. msgunfmt /usr/share/locale/az/LC_MESSAGES/gtk+.mo > gtk.po
2. msgconv -t UTF-8 < gtk.po > gtk8.po
  
Actual results:
msgconv: <stdin>: warning: Charset "iso-8859-9e" is not a portable encoding name.
                           Message conversion to user's charset might not work.
msgconv: present charset "iso-8859-9e" is not a portable encoding name


Expected results:
PO file converted to UTF-8

Additional info:
The underlying problem is that glic does not support ISO-8859-9E.

iconv -l

confirms this.

So either the encoding should be added to glibc, but that seems unneeded as this
seems to be the only MO file on the system with problems.

The other option is to convert the MO file to UTF-8 (but to do it properly you
would need the ISO-8859-9E format specified).  Opening this file in vim seems to
get the encoding correct but since I cannot tell if the characters are correct
or not I cannot be certain.
Comment 1 Rex Dieter 2007-07-06 10:08:01 EDT
Since this is a legacy-only package, I'm not sure if any heroic messures are
warranted to try to resolve this.

Patches are always welcome, of course.
Comment 2 Rex Dieter 2007-09-24 12:32:58 EDT
it's been awhile, might as well put this one to rest, CLOSING->WONTFIX.

Likely the only/best place to take the issue would be upstream to bugs.gnome.org
(then we could at least mark it UPSTREAM)

Comment 3 Rex Dieter 2007-09-26 09:26:45 EDT
thanks, good.

Note You need to log in before you can comment on or make changes to this bug.