Bug 246342 - hplip does not allow a queue to be created for Hp 5500
hplip does not allow a queue to be created for Hp 5500
Status: CLOSED DUPLICATE of bug 242974
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-30 14:17 EDT by Scott Berry
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-30 19:16:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Scott Berry 2007-06-30 14:17:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.0.3705; .NET CLR 1.1.4322; .NET CLR 2.0.50727; Media Center PC 4.0; .NET CLR 3.0.04506.30)

Description of problem:
I was trying to set up an Hp5500 and useed hp-setup to do this and went through the installer.  When I got done this is what I got as an error message:
root@jade:~
Setting up device: hp:/usb/officejet_5500_series?serial=MY49RG10J296                             
                                                                                                 
(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.)    
                                                                                                 
warning: One or more print queues already exist for this device: Hpofficejet5500, officejet_5500_
series.                                                                                          
                                                                                                 
Would you like to install another print queue for this device? (y=yes, n=no*, q=quit) ?y         
                                                                                                 
PRINT QUEUE SETUP                                                                                
                                                                                           oj5500
Using queue name: oj5500                                                                         
                                                                                                 
Found a possible PPD file: foomatic:HP-OfficeJet_5500-hpijs.ppd                                  
Desc: HP OfficeJet 5500 Foomatic/hpijs                                                           
                                                                                                 
Note: The model number may vary slightly from the actual model number on the device.             
                                                                                                 
Does this PPD file appear to be the correct one (y=yes*, n=no, q=quit) ?y                        
Enter a location description for this printer (q=quit) ?home                                     
Enter additonal information or notes for this printer (q=quit) ?homelocal                        
                                                                                                 
Adding print queue to CUPS:                                                                      
Device URI: hp:/usb/officejet_5500_series?serial=MY49RG10J296                                    
Queue name: oj5500                                                                               
PPD file: foomatic:HP-OfficeJet_5500-hpijs.ppd                                                   
Location: home                                                                                   
Information: homelocal                                                                          T
raceback (most recent call last):                                                                
  File "/usr/bin/hp-setup", line 623, in <module>                                                
    cups.addPrinter(printer_name, print_uri, location, print_ppd, info)                          
TypeError: addPrinter() takes exactly 6 arguments (5 given)                                      
[root@jade ~]#                                                                                   
[root@jade ~]# 

Version-Release number of selected component (if applicable):
1.7.2-13

How reproducible:
Always


Steps to Reproduce:
Go to the terminal.
2.  At the terminal go to your root acount.
3.  Once at root type "hp-setup".
4.  Follow the steps as expected.
5.  At the end you will see the error message I got.  However, I am unsure if this is every Hp printer or just certain ones.1.
2.
3.

Actual Results:
An error message came up see above in description.

Expected Results:
The queue should have been made properly.  The upstream developers I assume are aware of this but have provided no fix that I am aware of except for a couple of patches.

Additional info:
The computer which has the printer attached is a Dell Dimension 4600.
Comment 1 Tim Waugh 2007-06-30 19:16:10 EDT

*** This bug has been marked as a duplicate of 242974 ***

Note You need to log in before you can comment on or make changes to this bug.