This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 246350 - livecd-tools: disabling services
livecd-tools: disabling services
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-30 15:53 EDT by Jose Pedro Oliveira
Modified: 2013-03-05 22:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 13:57:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2007-06-30 15:53:25 EDT
Description of problem:
the livecd-creator script fails to disable a service in the runlevel 2
(it only disables the service in the runlevel 3-5).

Version-Release number of selected component (if applicable):
livecd-tools-009-1

How reproducible:
Always.

Steps to Reproduce:
1. create a live ISO based on the livecd-fedora-desktop.ks example
2. boot the ISO
3. check the sshd daemon chkconfig configuration
  
Actual results:
sshd will still start in the runlevel 2

Expected results:
Also disable the service in the runlevel 2.

Additional info:

By default sshd is enabled in 4 runlevels (2-5):

  $ chkconfig --list sshd
  sshd      0:off   1:off   2:on    3:on    4:on    5:on    6:off

The current version of livecd-creator only disables the service
in 3 runlevels (3-5).

Kickstart line:

   services --enabled=NetworkManager,dhcdbd --disabled=network,sshd

livecd-creator offending lines

   for s in self.ksparser.handler.services.disabled:
      subprocess.call(["/sbin/chkconfig", s, "--level", "345", "off"],

Fix:
diff -r livecd-tools-009-orig/creator/livecd-creator
livecd-tools-009/creator/livecd-creator
707c707
<                 subprocess.call(["/sbin/chkconfig", s, "--level", "345", "off"],
---
>                 subprocess.call(["/sbin/chkconfig", s, "--level", "2345", "off"],
Comment 1 Jeremy Katz 2007-07-06 09:41:55 EDT
Chris -- it's probably worth being consistent here with anaconda; what are you
doing there?
Comment 2 Chris Lumens 2007-07-10 10:28:02 EDT
instdata.py in anaconda does not specify any runlevel for enabling or disabling
services:

            for svc in self.ksdata.services.disabled:
                iutil.execWithRedirect("/sbin/chkconfig",
                                       [svc, "off"],
                                       stdout="/dev/tty5", stderr="/dev/tty5",
                                       root=anaconda.rootPath)

            for svc in self.ksdata.services.enabled:
                iutil.execWithRedirect("/sbin/chkconfig",
                                       [svc, "on"],
                                       stdout="/dev/tty5", stderr="/dev/tty5",
                                       root=anaconda.rootPath)

Should I change this to no longer just trust the defaults?
Comment 3 Jeremy Katz 2007-07-16 13:57:50 EDT
Not passing the runlevel looks like it falls back to 2345.  Adjusted
livecd-creator to not pass a level either

Note You need to log in before you can comment on or make changes to this bug.