Bug 246354 - 2 pointer cursors diverging under -vnc option
2 pointer cursors diverging under -vnc option
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-30 17:12 EDT by eric magaoay
Modified: 2008-04-22 12:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 12:09:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eric magaoay 2007-06-30 17:12:16 EDT
Description of problem:
when running qemu-kvm under under "-vnc" option, 2 pointer cursors are being
display and out of sync when seen from the remote monitor.


Version-Release number of selected component (if applicable):
kvm.x86_64 28-1.fc8
qemu.x86_64 0.9.0-2.fc7

How reproducible:
persisten

Steps to Reproduce:
1. command executed specific to my system: 
   qemu-kvm -boot c -localtime -usbdevice tablet -vnc :84 -monitor stdio hda
/a/img/fdev -m 400 -net nic,vlan=84,macaddr=52:54:00:12:44:84 -net
tap,vlan=84,ifname=tap84,script=/a/q/qifup.tap

2. assuming the IP address quest VM is bind to bridge IP (192.168.3.80)
   from a remote client viewer execute:
    
   vncviewer 192.168.3.80::5984

Actual results:
Observer the double cursors diverging. 

Expected results:
using "-usbdevice tablet" should have resolved the above problem, but it does NOT.
Comment 1 Daniel Berrange 2007-08-28 16:51:28 EDT
Using '-usbdevice tablet'  provides the neccessary virtual hardware to enable
the OS to be configured to have sane pointer. It does not neccessarily solve it
on its own. Windows will autodetect & configure a USB tablet. Linux will not -
/etc/X11/xorg.conf needs manual editing to enable the USB tablet & disable the
PS/2 mouse. Please provide info on what guest OS you're using ?
Comment 2 eric magaoay 2007-08-29 14:12:43 EDT
It failed on FC7 release. I am testing it on the latest rawhide but I'm getting
kernel panic on x86_64 during boot-up install, and on i386 install I'm getting
traceback from anaconda. 

I'm not sure how to capture the kernel panic through KVM piped to serial
console, any suggestion?

eric
Comment 3 eric magaoay 2007-09-21 14:43:57 EDT
I just tested the latest rawhide build dated 9-20-07 (also tested on F8test2)
and the diverging mouse pointer problem exist only when you run qemu-kvm from
the REMOTE terminal/viewer. There is no problem when running from the host terminal.

Host and Guest OS are the same build: 
kernel x86_64 2.6.23-0.185.rc6.git7.fc8
kvm x86_64 36-2.fc8
qemu x86_64 0.9.0-4.fc8

eric
Comment 4 Bug Zapper 2008-04-04 08:53:36 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 5 eric magaoay 2008-04-22 12:09:49 EDT
I couldn't test this on the latest FC9 build (4/22/08) due to PXE VNC install
failing. Works OK for FC8 and updating to FC9 rawhide. So I say for now it looks OK.

Note You need to log in before you can comment on or make changes to this bug.