Bug 246381 - gtk2 must be installed due to grub's dependencies
gtk2 must be installed due to grub's dependencies
Status: CLOSED DUPLICATE of bug 243491
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-01 10:22 EDT by Sam Varshavchik
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-04 12:09:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2007-07-01 10:22:02 EDT
Description of problem:

On a headless server, I am now forced to installed a lot of gtk2 baggage due to
grub's dependencies.

Version-Release number of selected component (if applicable):

grub-0.97-13

How reproducible:

Always

Steps to Reproduce:
1. Try to do a minimal install for a headless server that's supposed to be a
simple Internet firewall/proxy.
2. Try to remove all the baggage that gets loaded
  
Actual results:

[root@headache ~]# rpm -e gtk2
error: Failed dependencies:
        libgdk-x11-2.0.so.0 is needed by (installed) gtk2-engines-2.10.2-2.fc7.i386
        libgdk_pixbuf-2.0.so.0 is needed by (installed)
gtk2-engines-2.10.2-2.fc7.i386
        libgtk-x11-2.0.so.0 is needed by (installed) gtk2-engines-2.10.2-2.fc7.i386
        gtk2 >= 2.9.0 is needed by (installed) gtk2-engines-2.10.2-2.fc7.i386
[root@headache ~]# rpm -e gtk2-engines
error: Failed dependencies:
        gtk2-engines >= 2.9.0 is needed by (installed)
gnome-themes-2.18.0-1.fc7.noarch
        gtk2-engines >= 2.9.4-2 is needed by (installed)
redhat-artwork-7.0.0-11.fc7.i386
[root@headache ~]# rpm -e gnome-themes redhat-artwork fedora-logos
error: Failed dependencies:
        system-logos is needed by (installed) grub-0.97-13.i386

Expected results:

I should not have to have the entire gnome/gtk2 stack installed, just because of
grub. Somewhere along this chain of dependencies, things need to be refactored,
a bit.

Additional info:
Comment 1 Sam Varshavchik 2007-07-01 10:23:34 EDT
Ommited a small step from cut-paste:

The fedora-logos dependency is due to this:

[root@headache ~]# rpm -e gnome-themes redhat-artwork
error: Failed dependencies:
        redhat-artwork is needed by (installed) fedora-logos-6.0.98-3.fc7.noarch
Comment 2 Mark McLoughlin 2007-07-04 12:09:57 EDT

*** This bug has been marked as a duplicate of 243491 ***

Note You need to log in before you can comment on or make changes to this bug.