Bug 246397 - cannot import name KeyboardWindow
Summary: cannot import name KeyboardWindow
Status: CLOSED DUPLICATE of bug 242844
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-01 19:27 UTC by Eric Bunton
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-12 02:28:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Bunton 2007-07-01 19:27:04 UTC
Description of problem:
I start the Fedora 7 installation. I then choose my language, English. Click
next and it says: "An error occurred when attempting to load an installer
interface component.
className = KeyboardWindow"

So I click exit, and in the shell I'm in I also see this:
Running anaconda, the Fedora system installer - please wait...
Probing for video card: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]
Attempting to start native X server
Waiting for X Server to start...log located in /tmp/ramfs/X.log
1...2...3...4...5... X server started successfully.
Starting graphical installation...

(anaconda:551): HtmlUtil-CRITICAL **: html_stream_cancel: assertion
'stream->cancel_func !=NULL' failed

(anaconda:551): HtmlUtil-CRITICAL **: html_stream_cancel: assertion
'stream->cancel_func !=NULL' failed

(anaconda:551): HtmlUtil-CRITICAL **: html_stream_cancel: assertion
'stream->cancel_func !=NULL' failed

(anaconda:551): HtmlUtil-CRITICAL **: html_stream_cancel: assertion
'stream->cancel_func !=NULL' failed
cannot import name KeyboardWindow

Then the computer reboots.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Put F7 Install DVD into computer.
2.Start graphical installation.
3.Choose language and click next.
  
Actual results:
Instalation stops and I am forced to reboot the computer.

Expected results:
The installation chould have continued normally and finished.

Additional info:
I get a similar error when running the installation in text mode.

Comment 1 Jeremy Katz 2007-07-06 19:35:33 UTC
Did you veirfy your installation media?

Comment 2 Eric Bunton 2007-07-07 15:26:21 UTC
(In reply to comment #1)
> Did you veirfy your installation media?

Yes I verified the media and it said it passed. I even cleaned the disc and 
the drive and I still get the same error.


Comment 3 Chris Lumens 2007-07-12 02:28:59 UTC
242844 has the same error message with a different component.  It's bound to be
the same root cause.

*** This bug has been marked as a duplicate of 242844 ***


Note You need to log in before you can comment on or make changes to this bug.