Bug 246414 - "restart login screen with chosen language" hangs
"restart login screen with chosen language" hangs
Status: CLOSED DUPLICATE of bug 240853
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-01 22:47 EDT by Jens Petersen
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 23:12:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ps aux output when gdm hangs (5.61 KB, text/plain)
2007-07-29 10:17 EDT, Hans de Goede
no flags Details

  None (edit)
Description Jens Petersen 2007-07-01 22:47:37 EDT
Description of problem:
It is nice that gdm now offers to restart in the newly chosen language
- unfortunately it seems to hang for me every time I click Yes.

Version-Release number of selected component (if applicable):
gdm-2.19.3-3.fc8

How reproducible:
every time

Steps to Reproduce:
1. chose a new lang in gdm
2. answer Yes to restart dialog
  
Actual results:
Black screen with cursor over "hourglass".

Expected results:
gdm to restart in new language

Additional info:
After that have to "killall gdm-binary" to restart gdm.
Comment 1 Hans de Goede 2007-07-29 10:17:38 EDT
Created attachment 160191 [details]
ps aux output when gdm hangs

I can reproduce this with gdm-2.19.4-1.fc8.x86_64, I think it should be easy to
fix I've attached the output of  "ps aux" when the hang happens, it seems that
gdm-greeter has died, but hasn't been reaped yet, so maybe a waitpid on the
wrong pid, or something like that.
Comment 2 Jens Petersen 2007-08-24 02:35:43 EDT
I see the "[gdmgreeter] <defunct>" too FWIW.

It would be good to fix this but if we can't for F8 then IMHO the feature 
should be disabled since it is highly annoying.

("killall gdm-binary" does bring back a new login screen, but that is not
an option for normal users.)
Comment 3 Ray Strode [halfline] 2007-08-24 10:10:04 EDT
yea, we should fix this before F8 (but not until after feature freeze, test 2)
Comment 4 Jens Petersen 2007-08-29 23:12:47 EDT

*** This bug has been marked as a duplicate of 240853 ***

Note You need to log in before you can comment on or make changes to this bug.