Bug 246425 - failure to ship pnm2ppa causes functional regressions for customers
failure to ship pnm2ppa causes functional regressions for customers
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.0
All Linux
high Severity high
: rc
: ---
Assigned To: Tim Waugh
Daniel Riek
:
Depends On: 455269
Blocks: 391501 296411 RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2007-07-02 03:14 EDT by Norm Murray
Modified: 2010-10-22 12:01 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
For this release, Red Hat is re-adding pnm2ppa in order to provide support for legacy printers. Note, however, that this support is deprecated and will be discontinued in future major releases.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-30 10:01:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Norm Murray 2007-07-02 03:14:03 EDT
Customer is attempting to configure an HP DeskJet 820C Printer

Using system-config-printer, when selecting this model printer the following is
displayed on console:
HP-DeskJet_820C foomatic:HP-DeskJet_820C-pnm2ppa.ppd
PPD name: foomatic:HP-DeskJet_820C-pnm2ppa.ppd
Cups PPD
/usr/bin/gs: found
pnm2ppa: NOT found in /usr/bin:/bin

And the resulting queue does not print to the device. Simply adding the RHEL 4
version of pnm2ppa enables this to print successfully.
Comment 1 RHEL Product and Program Management 2007-07-02 04:29:27 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 5 RHEL Product and Program Management 2007-11-09 13:55:36 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 8 RHEL Product and Program Management 2008-07-14 09:56:03 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 24 Daniel Riek 2008-09-29 10:19:14 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Red Hat is re-adding support for pnm2ppa for legacy printers. Note though that this support is deprecated and will be discontinued in future major releases.
Comment 26 Daniel Riek 2008-09-30 09:57:21 EDT
Given that pnm2ppa seems to be only required to support very old legacy printers, Product Management does not consider it appropriate to re-add this support to Enterprise Linux 5.

It is not a regression if support for hardware is discontinues, that is not available anymore and not supported by the vendor anymore.
Comment 27 RHEL Product and Program Management 2008-09-30 10:01:41 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request.
Comment 28 Don Domingo 2008-11-09 23:44:02 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-Red Hat is re-adding support for pnm2ppa for legacy printers. Note though that this support is deprecated and will be discontinued in future major releases.+For this release, Red Hat is re-adding pnm2ppa in order to provide support for legacy printers. Note, however, that this support is deprecated and will be discontinued in future major releases.

Note You need to log in before you can comment on or make changes to this bug.