Bug 246447 - Missing Dependency - mono-data-sqlite
Missing Dependency - mono-data-sqlite
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: monodevelop (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-02 06:06 EDT by Mohd Izhar Firdaus Ismail
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 10:25:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mohd Izhar Firdaus Ismail 2007-07-02 06:06:36 EDT
Description of problem:
Monodevelop refuses to start if mono-data-sqlite is unavailable

Version-Release number of selected component (if applicable):
monodevelop-0.13.1-1.fc7

How reproducible:
All the time

Steps to Reproduce:
1.from a system that doesnt have any mono development packages installed, yum
install monodevelop
2.launch monodevelop
  
Actual results:

[kagesenshi@Hikari ~]$ monodevelop 

** (MonoDevelop:11998): WARNING **: The following assembly referenced from
/usr/lib/monodevelop/AddIns/MonoQuery/Mono.Data.Sql.dll could not be loaded:
     Assembly:   Mono.Data.SqliteClient    (assemblyref_index=7)
     Version:    2.0.0.0
     Public Key: 0738eb9f132ed756
The assembly was not found in the Global Assembly Cache, a path listed in the
MONO_PATH environment variable, or in the location of the executing assembly
(/usr/lib/monodevelop/bin/../AddIns/MonoQuery).


** (MonoDevelop:11998): WARNING **: Could not load file or assembly
'Mono.Data.SqliteClient, Version=2.0.0.0, Culture=neutral,
PublicKeyToken=0738eb9f132ed756' or one of its dependencies.
2007-07-02 17:51:43,845 [1115872] ERROR MonoDevelop.Core.ILoggingService
[(null)] - Add-in failed to load: MonoQuery
2007-07-02 17:51:43,895 [1115872] ERROR MonoDevelop.Core.ILoggingService
[(null)] - System.Reflection.ReflectionTypeLoadException: The classes in the
module cannot be loaded.
  at <0x00000> <unknown method>
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] 
  at MonoDevelop.Core.AddIns.DefaultAddInTree.LoadCodonsAndConditions
(System.Reflection.Assembly assembly) [0x00000] 
  at MonoDevelop.Core.AddIns.DefaultAddInTree.LoadAssembly (System.String
fileName) [0x00000] 
  at MonoDevelop.Core.AddIns.AddIn.AddRuntimeLibraries (System.String path,
System.Xml.XmlElement el) [0x00000] 
  at MonoDevelop.Core.AddIns.AddIn.ReadXmlContents (System.String fileName,
System.Xml.XmlElement elem) [0x00000] 
  at MonoDevelop.Core.AddIns.AddIn.Initialize (System.String fileName) [0x00000] 
  at MonoDevelop.Core.AddIns.AddInTreeSingleton.InsertAddIn (System.String
addInFile) [0x00000] 

Expected results:
It runs

Additional info:
yum install mono-data-sqlite fixes the issue
Comment 1 Gilboa Davara 2007-10-25 11:32:38 EDT
Owner seems to be MIA.
Has anyone contacted him?
Comment 2 Paul F. Johnson 2007-11-13 10:32:38 EST
Sorry - been away for quite a while. 0.17b2 is in rawhide currently.
Comment 3 Paul F. Johnson 2007-11-14 10:25:56 EST
Fixed in rawhide. Give it a spin and let me know. Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.