Bug 246510 - anaconda fails when creating a SW RAID device
anaconda fails when creating a SW RAID device
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-02 14:58 EDT by Herb Goodfellow Jr.
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-30 13:19:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Herb Goodfellow Jr. 2007-07-02 14:58:27 EDT
Description of problem:
Installing RHEL5 on a system with two 500GB SATA HD's using the instructions
found on pages 49-60 of the Deployment Guide fails.  The bug that is identified
buy the system is 10 pages long and I can not get it from the system to here w/o
hand typing it.  It says that multiple lines related to the .py code in the
Anaconda system can not "identify the hard drive (or disk I can't remember).  

The system has 4GB of RAM is a 2GHZ Dual Core Intel on an Intel 
DQ965GF mother board.  To get the install to start I have to use "linux
all-generic-ide mem=2048mb pci=nommconf"  The BIOS is set to legacy IDE.  I have
tried to get the HW RAID to work and oddly enough the problem is the same.

In Disk Druid I follow the instructions for making a multiple md device (0 for
/boot (RAID1) 1 for SWAP (RAID0) and 2 for / (RAID1).  I then configure all the
packages I want and the system looks at all of the dependencies that need to be
installed.  It says "I am ready and I need all 6 CDs to do this" and I say "no
problem get started..."  then BANG it fails with a picture of a bug on the
screen and instructions to put the text here.

After trying MANY different configs that all end in the same result I am left to
conclude that you can ONLY install RHEL5 if you want the default LVM setup or if
you want to install on /dev/hda ONLY.  With the /dev/md2 deal it fails as badly
as it does with the /dev/HWRAIDDEVSTRING that I can't remember.  

I'd sure like to know how to fix this or at least take my default /dev/hda
install and mirror the whole disk to /dev/hdc.  CAn you all walk me through
this?  I am will to pay for RHEL support for things that are my fault or
particular to my job; however, I feel this one should be on you all since the
install process does not work as advertised.

Version-Release number of selected component (if applicable):


How reproducible:
VERY easily reproduced.

Steps to Reproduce:
1. Get a Intel board in PC w/a Core Duo chip, 4GB of RAM and 2 SATA 500GB drives. 
2. Run the install process 
3. Make a /dev/mdX device and try to finish the install with it.

  
Actual results:
see above

Expected results:
A Bootable system with SW RAID'd HD's like the Deployment Guide says should work.

Additional info:
I can be reached at 571 283 5492.
Comment 1 Herb Goodfellow Jr. 2007-07-02 18:34:44 EDT
NOTE: This issue seems to be relevant to Intel motherboards.  I have returned it
and have purchased an Asus w/an AMD 4600+ and all is well.  The /dev/md# stuff
from disk druid seems to work well.  
Comment 2 Chris Lumens 2007-08-23 16:22:00 EDT
At a minimum, please attach the python traceback to this bug report so we can
see exactly where things are failing.  If you have no other way of getting this
information, attaching pictures of the screen is fine.  You can find more
information on reporting anaconda bugs at:

http://www.fedoraproject.org/wiki/AnacondaBugReporting
Comment 3 Chris Lumens 2007-08-30 13:19:10 EDT
Closing since hardware is no longer available for testing.  Feel free to reopen
this bug if you experience this problem again in the future.

Note You need to log in before you can comment on or make changes to this bug.