Bug 246536 - gcalctool doesn't accept negative exponential input anymore
Summary: gcalctool doesn't accept negative exponential input anymore
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcalctool   
(Show other bugs)
Version: 7
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-02 21:43 UTC by Jonathan Underwood
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-02 21:45:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Underwood 2007-07-02 21:43:28 UTC
Description of problem:
It is no longer possible to enter a negative exponent. Eg, try to eneter
6.626e-34. Pressing the Exp button allows you to enter a positive exponent.
Pressing the +/- then removes the exponent! This is in "left to right precedence
mode"

Version-Release number of selected component (if applicable):
gcalctool-5.9.14-1.fc7

How reproducible:
Everytime

Steps to Reproduce:
1.Try to enter 6.626e-34

Comment 1 Jonathan Underwood 2007-07-02 21:45:46 UTC
OK, sorry. When it was resetting to 0, it was because I was in "Fix" mode. What
a crap UI. Surely whenever you enter a number that can't be displayed in Fix
format it should switch to Sci. Oh well, closing bug.


Note You need to log in before you can comment on or make changes to this bug.