Bug 246540 - [PATCH]: add etags man pages to alternatives framework
[PATCH]: add etags man pages to alternatives framework
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Chip Coldwell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-02 18:09 EDT by Terje Røsten
Modified: 2008-10-20 14:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 14:11:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patct to implement the change (1009 bytes, text/plain)
2007-07-02 18:09 EDT, Terje Røsten
no flags Details

  None (edit)
Description Terje Røsten 2007-07-02 18:09:36 EDT
Description of problem:

Emacs package is using alternatives to let users switch between etags
implementations, however the etags manual page is not handle by the
alternatives framework.

This can be done using the --slave option, (see e,g. sendmail/postfix packages).

A simple patch to do this is attached.

Note: I had to move the alternatives command to %posttrans,

if not the link 

/usr/share/man/man1/etags.1.gz -> /etc/alternatives/etags-etagsman

would not be created by alternatives.


BTW: does it make sense to have %changelog going back ten years?

(Abuse Emacs 22,1 release to make much shorter?)
Comment 1 Terje Røsten 2007-07-02 18:09:36 EDT
Created attachment 158384 [details]
patct to implement the change
Comment 2 Terje Røsten 2008-02-17 13:59:04 EST
A bit puzzled by the silence workflow here, this seems to be fixed since 22.1-9:

http://cvs.fedoraproject.org/viewcvs/rpms/emacs/devel/emacs.spec?r1=1.102&r2=1.103&makepatch=1&diff_format=h


Comments?
Comment 3 Bug Zapper 2008-05-13 23:01:06 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Terje Røsten 2008-10-20 14:11:27 EDT
Closing, seems to be fixed ages ago.

Note You need to log in before you can comment on or make changes to this bug.