This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 246570 - cimserver should be started after reboot
cimserver should be started after reboot
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tog-pegasus (Show other bugs)
4.0
All Linux
low Severity urgent
: ---
: ---
Assigned To: Vitezslav Crhonek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 02:12 EDT by Madhusmita Sahu
Modified: 2008-09-09 11:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 11:21:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Madhusmita Sahu 2007-07-03 02:12:00 EDT
Description of problem:

We use tog-pegasus-2.5.2-5.el5.We observed that cimserver is not restarted 
automatically after reboot.We have to start manually.Currently we have added 
"chkconfig --level 2345 tog-pegasus on" command in our post install scripts to 
handle it.But it seems adding xhkconfig --level command in post install scripts 
is against Red Hat policy.Could you please let us know about the availabuility 
of this feature as we need cimserver to be restarted automatically to maintain 
HA of our product.

Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux Server release 5 (Tikanga) and RHEL4 also. 
How reproducible:


Steps to Reproduce:
1. install tog-pegasus.cimserver should be running 
2. reboot the machine
3. check ps -aef | grep cimserver 
  
Actual results:

cimserver is not running.

Expected results:
cimserver should be running after reboot.

Additional info:

For any additional info please mail me : madhusmitas@hp.com
Comment 1 Vitezslav Crhonek 2007-08-30 05:14:40 EDT
Hi,

I have just tryed it in RHEL5 and it works for me... My steps:

1. install tog-pegasus (cimserver is not running by default)
2. start service (/sbin/service tog-pegasus start)
3. set what you need (/sbin/chkconfig --level 2345 tog-pegasus on)
4. reboot

After reboot, setting of service persist and service is runnig.
Using GUI setting tool, result is same as in console.
Is there something what you do in different way?
Comment 2 Vitezslav Crhonek 2008-09-09 11:21:07 EDT
Well, it is against policy.

But you should try add "/sbin/chkconfig --add tog-pegasus" to post install script.

Note You need to log in before you can comment on or make changes to this bug.