Bug 246587 - SMTP AUTH=client fails available mechanisms
Summary: SMTP AUTH=client fails available mechanisms
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: sendmail   
(Show other bugs)
Version: 7
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-03 08:55 UTC by Allen Kistler
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-03 09:31:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Allen Kistler 2007-07-03 08:55:31 UTC
Description of problem:
Sendmail as an SMTP AUTH client does not even try to authenticate, despite
available mechanisms.  The result is that sendmail fails to relay mail for
authenticated connections.  The only workaround is to regress to a previous
version of sendmail from fc5.

Version-Release number of selected component (if applicable):
sendmail-8.14.1-2

How reproducible:
Always

Steps to Reproduce:
1. Define SMART_HOST in sendmail.mc & compile to cf with m4
2. Define Authinfo "M:LOGIN PLAIN" in access & compile to db with makemap
3. Send mail which requires authenticated relaying
  
Actual results:
Packet capture shows that
1. sendmail EHLO elicits "250 AUTH LOGIN PLAIN" from SMART_HOST
2. sendmail sends "QUIT" immediately
3. sendmail logs "AUTH=client, available mechanisms do not fulfill requirements"

Expected results:
sendmail should authenticate using the perfectly adequate, available mechanisms
and relay mail

Additional info:
Removing the authinfo from access.db results in the correct "Authentication
Required" error in bounced mail, so sendmail is reading access.db.  It just
doesn't authenticate when the proper authinfo really is present.

The same settings in sendmail-8.13.8-1.fc5 work fine in fc5.

Comment 1 Allen Kistler 2007-07-03 09:31:08 UTC
After beating my head against this for yet more time, I installed
cyrus-sasl-plain, which solved the problem.

Hmmm...  I'm disinclined to insist on adding cyrus-sasl-plain to the "Requires"
list, since most folks never use sendmail in client auth, but after Googling
like crazy, I would have expected a FAQ about it.  Oh, well.  Closing ....

Comment 2 Thomas Woerner 2007-07-25 11:22:20 UTC
The next package in devel will have a notice for this, thanks.


Note You need to log in before you can comment on or make changes to this bug.