This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 246614 - mock doesn't report rpmbuild error
mock doesn't report rpmbuild error
Status: CLOSED DUPLICATE of bug 244596
Product: Fedora Hosted Projects
Classification: Retired
Component: mock (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Clark Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 09:10 EDT by Jeff Sheltren
Modified: 2013-01-09 23:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 08:46:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Sheltren 2007-07-03 09:10:03 EDT
When building a package with the latest mock version, mock-0.7.2-1.fc6.1,
rpmbuild errors don't get caught by mock - it exits normally.

Version-Release number of selected component (if applicable):
mock-0.7.2-1.fc6.1

How reproducible:
Always

Steps to Reproduce:
1. Create an SRPM which would generate rpmbuild errors (example: installed file
not listed in %files)
2. Run mock to build that SRPM
  
Actual results:
mock exits with 0 status, no error messages printed out:
----------
init
clean
prep
This may take a while
unpack cache
setup
build
ending
done
Results and/or logs in: /var/lib/mock/fedora-6-i386-core/result

$ echo $?
0

$ tail -3 /var/lib/mock/fedora-6-i386-core/result/build.log 
RPM build errors:
    Installed (but unpackaged) file(s) found:
   /etc/yum.repos.d/cs-testing.repo
----------


Expected results:
mock should report/display rpmbuild error and exit with some error code.
Comment 1 Mohd Izhar Firdaus Ismail 2007-07-03 09:14:18 EDT
I'm getting the same problem with mock-0.7.2-1.fc7
Comment 2 Jeff Sheltren 2007-07-18 08:46:30 EDT

*** This bug has been marked as a duplicate of 244596 ***

Note You need to log in before you can comment on or make changes to this bug.