Bug 246632 - automake needs g++ when using c-only source
Summary: automake needs g++ when using c-only source
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: automake   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Stepan Kasal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-03 15:06 UTC by Adam Tkac
Modified: 2013-04-30 23:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 14:38:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Tkac 2007-07-03 15:06:52 UTC
Description of problem:
I rewritting BIND build schema to autotools and have problems with generated
configure

Version-Release number of selected component (if applicable):
rpm -q automake
automake-1.10-5

How reproducible:
only with my snapshot

Steps to Reproduce:
1. dowload snapshot of my work
2. generate configure (aclocal -> automake -> autoconf or autoreconf)
3. run generated configure
  
Actual results:
./configure dies with
configure: error: conditional "am__fastdepCXX" was never defined.
Usually this means the macro was only invoked conditionally.

Expected results:
good configure script

Additional info:
You could download affected source from
http://people.redhat.com/atkac/bind-9.5.0a6.tar.bz2 . configure.ac is very long
and have many confusions so this could be my mistake. But when I add AC_PROG_CXX
into configure.ac all works as expected.

Comment 1 Stepan Kasal 2007-10-31 14:38:39 UTC
The tarball mentioned in the description is no longer available on
people.redhat.com.
I do not remmeber details, but I think that the autoconfigury in the tarball was
invalid.  So this is not a bug.  (Though the error message may not be ideal.)


Note You need to log in before you can comment on or make changes to this bug.