Bug 246645 - horizontally squashed 1680x1050 display with g965, viewsonic Q20wb
horizontally squashed 1680x1050 display with g965, viewsonic Q20wb
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 12:50 EDT by J. Bruce Fields
Modified: 2008-01-14 18:54 EST (History)
2 users (show)

See Also:
Fixed In Version: f8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 18:54:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.22 KB, text/plain)
2007-07-04 13:33 EDT, J. Bruce Fields
no flags Details
Xorg.0.log (58.57 KB, text/plain)
2007-07-04 13:35 EDT, J. Bruce Fields
no flags Details
Xorg.0.log (after removing xorg.conf) (75.03 KB, text/plain)
2007-07-04 13:45 EDT, J. Bruce Fields
no flags Details

  None (edit)
Description J. Bruce Fields 2007-07-03 12:50:56 EDT
Description of problem:

Both the OS and the monitor report that a 1680x1050 resolution is being used. 
That's the correct resolution.  Taking a screenshot, e.g., also produces a
1680x1050 resolution image.  However, the image doesn't horizontally fill the
whole monitor; there's a large black band on the left side and a smaller band on
the right.  Manual adjustment of the horizontal image size using the monitor's
menu doesn't help; setting the horizontal size to the maximum possible leaves
the image about the same.

I'm using the "intel" driver.  The "i810" driver refuses to use 1680x1050 at all
(even after fooling with the bios table with 915resolution).

The monitor is a ViewSonic Q20wb.

Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-2.0.0-5.fc8
Comment 1 Matěj Cepl 2007-07-04 09:15:39 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 J. Bruce Fields 2007-07-04 13:33:26 EDT
Created attachment 158529 [details]
xorg.conf
Comment 3 J. Bruce Fields 2007-07-04 13:35:43 EDT
Created attachment 158530 [details]
Xorg.0.log
Comment 4 J. Bruce Fields 2007-07-04 13:42:59 EDT
OK, I renamed /etc/X11/xorg.conf.  The result is an image that exactly fills the
whole screen (no more black bars on either side), but the resolution is now
1600x1200, which looks pretty awful on an LCD with native 1680x1050 resolution.
 The "Screen Resolution" dialog doesn't give me the option of switching to
1680x1050.

I'll attach the new log.
Comment 5 J. Bruce Fields 2007-07-04 13:45:24 EDT
Created attachment 158533 [details]
Xorg.0.log (after removing xorg.conf)

This is the contents of /var/log/Xorg.0.log after renaming /etc/X11/xorg.conf,
logging out, and logging back in again.
Comment 6 J. Bruce Fields 2007-07-20 13:33:54 EDT
I experimented with modelines, and found I could get an acceptable image with

Section "Monitor"
        Identifier   "Monitor0"
        HorizSync    31.5 - 90.0
        VertRefresh  50.0 - 60.1
        Option      "dpms"
        Modeline  "JBF-1680x1050"  146.25  1680 1754 1930 2300  1050 1053 1059 1
089 +hsync -vsync
EndSection

(The default mode otherwise selected is
"1680x1050"   146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync
)

I know nothing about modelines, so this was found just by taking a mode out of
the log file and experimenting.

What needs to be done to get this working by default?
Comment 7 Jesse Barnes 2008-01-10 18:12:01 EST
The log you posted seems to be from the i810 driver, rather than the intel 
driver.  Can you try the latter and see if it works for you?  If not, it may 
be having trouble getting EDID info from your monitor or the data is bogus...
Comment 8 J. Bruce Fields 2008-01-14 13:09:03 EST
Sorry for the confusion; I did have problems with both drivers, but I've lost
track of the details now.

I'm now using FC8 (not rawhide), for x86_64 (not 32-bit any more), with the same
machine (and same monitor), and the default setup (it seems to have chosen the
"intel" driver) no longer has any problems.  This is just with the default
xorg.conf, no manual modeline setting.
Comment 9 Matěj Cepl 2008-01-14 18:54:56 EST
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.