Bug 246646 - system-config-lvm displays physical volumes in bad order
system-config-lvm displays physical volumes in bad order
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-lvm (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Marek Grac
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 12:53 EDT by Stepan Kasal
Modified: 2009-09-21 07:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-21 07:26:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stepan Kasal 2007-07-03 12:53:34 EDT
start system-config-lvm
select a volume group "delta" which contains /dev/sda{11,12,8}

The picture displays the "red" pv's as this:
   sda8 sda12 sda11
This is the reverse of "the right order."

Note that under the "delta Physical View | /dev/sda" (in the left pane), the
order is:
   Partition 11
   Partition 12
   Partition 8
which is also the order in which the pv's get allocated to a lv.
This is "the right order".

Please change the order used for the overall graphical display.
Comment 1 Marek Grac 2009-09-21 07:26:17 EDT
Physical devices that are not in used are shown at the right. In some cases, it is possible that it looks like you explained. But there is no 'right order', for different allocation strategies results could differs.

Note You need to log in before you can comment on or make changes to this bug.