Bug 246647 - Can't start DS when PID in the PID files matches the PID of non-DS process
Summary: Can't start DS when PID in the PID files matches the PID of non-DS process
Status: CLOSED DUPLICATE of bug 245894
Alias: None
Product: 389
Classification: Retired
Component: Command Line Utilities   
(Show other bugs)
Version: 1.0.4
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Noriko Hosoi
QA Contact: Orla Hegarty
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 152373 240316
TreeView+ depends on / blocked
 
Reported: 2007-07-03 16:57 UTC by Noriko Hosoi
Modified: 2007-07-03 19:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-03 19:11:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Noriko Hosoi 2007-07-03 16:57:27 UTC
Description of problem:
When the Directory Server abnormally exits and leaves PID files, the pid rarely
matches the pid of other existing process.  It prevents the server's start.

Step to reproduce:
$ ps -ef | egrep 1111
nhosoi    1111  9492  0 Jun22 pts/2    00:00:00 vim bogus
# stop the server:
$ lib/fedora-ds/slapd-laputa/stop-slapd
# create pid files that store the existing pid 1111:
$ echo 1111 > var/run/fedora-ds/slapd-laputa.pid
$ echo 1111 > var/run/fedora-ds/slapd-laputa.startpid
# start the server:
$ lib/fedora-ds/slapd-laputa/start-slapd
There is an ns-slapd process already running: 1111

The check is being done in start-slapd.  We could check the process name and
remove the pid files and start the server if the process is not ns-slapd.

Comment 1 Noriko Hosoi 2007-07-03 19:11:54 UTC

*** This bug has been marked as a duplicate of 245894 ***


Note You need to log in before you can comment on or make changes to this bug.