Bug 246668 - exportfs returns hostnames instead of IPs causing problems with nfsclient.sh
exportfs returns hostnames instead of IPs causing problems with nfsclient.sh
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: Ryan O'Hara
Cluster QE
:
: 428702 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 15:18 EDT by Lon Hohberger
Modified: 2010-10-22 12:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 17:13:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes behavior (1.33 KB, patch)
2007-07-03 15:18 EDT, Lon Hohberger
no flags Details | Diff
Fixes behavior (9.21 KB, patch)
2007-07-03 15:19 EDT, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Lon Hohberger 2007-07-03 15:18:01 EDT
Description of problem:

Because exportfs tries DNS / host resolution of IPs when displaying the list of
exports (exportfs -v), exporting to a client via IP address in cluster.conf
causes an erroneous "nfsclient:<ip> missing" message.


Version-Release number of selected component (if applicable): RHEL4.5


How reproducible: 100%


Steps to Reproduce:
1. Create an nfsclient resource with an IP as the target
2. Attach the nfsclient resource to a service...
3. Start service
4. wait for status checks
  
Actual results: Resource is constantly restarted.

Expected results: Resource is not restarted since it wasn't a real error
Comment 1 Lon Hohberger 2007-07-03 15:18:01 EDT
Created attachment 158469 [details]
Fixes behavior
Comment 2 Lon Hohberger 2007-07-03 15:19:14 EDT
Created attachment 158470 [details]
Fixes behavior

This script can be dropped in /usr/share/cluster to fix the problem on live
systems.
Comment 3 Lon Hohberger 2007-09-24 16:18:33 EDT
The real place to fix this is in exportfs - as in, providing a query to ask the
kernel if a particular export was still valid or not.
Comment 5 Lon Hohberger 2007-12-11 09:51:33 EST
How was this resolved ?  We never put it in a release...
Comment 8 Lon Hohberger 2008-01-28 14:54:18 EST
*** Bug 428702 has been marked as a duplicate of this bug. ***
Comment 10 Ryan O'Hara 2008-10-05 12:23:30 EDT
Fixed in RHEL4 tree.
Comment 13 errata-xmlrpc 2009-05-18 17:13:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1048.html

Note You need to log in before you can comment on or make changes to this bug.