Bug 246702 - Kernel panic in Xen
Kernel panic in Xen
Status: CLOSED DUPLICATE of bug 233543
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
i686 Linux
low Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Depends On:
  Show dependency treegraph
Reported: 2007-07-04 03:20 EDT by Daniel Fosselius
Modified: 2008-02-26 21:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-26 21:55:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
whole kernel panic (19.80 KB, text/plain)
2007-07-04 03:20 EDT, Daniel Fosselius
no flags Details

  None (edit)
Description Daniel Fosselius 2007-07-04 03:20:52 EDT
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:
I have installed  RHEL 5 with virtualization and creates a virtual machine with
2GB RAM and one VCPU in virt-manager that runs RHEL 4.5. The installation goes
fine but then when i shutdown the virtual machine and start it again, i get a
kernel panic.

The problem is that i doesnt get the error everytime i boot the machine, it
looks like it reproduces when i have several virtual machines and take them up
and down. I also had a virtual machine that got kernel panic everytime, when i
changed the amount of memory to 1GB it booted, so it looks like memory problems.

I have only used paravirtualizated machines and tested both with partition and
image file. I have run memtest on the host machine and found no errors. 

hardware: HP DL380 with 2CPU:s and 12GB RAM

Steps to Reproduce:
1.Create a paravirtualizated host with virt-manager with 2GB RAM and 1 cpu
2.Install RHEL 4.5
3. boot the virtual machine
4. shutdown the virtual machine
5. change memory settings in the configurationfile to 4GB
6. boot the virtual machine
Actual results:
kernel panic
------------[ cut here ]------------
kernel BUG at arch/i386/mm/pgtable-xen.c:306!
invalid operand: 0000 [#1]
Modules linked in: dm_snapshot dm_zero dm_mirror ext3 jbd dm_mod xenblk sd_mod
CPU:    0
EIP:    0061:[<c011163a>]    Not tainted VLI
EFLAGS: 00010282   (2.6.9-55.ELxenU)
EIP is at pgd_ctor+0x1d/0x26
eax: fffffff4   ebx: 00000000   ecx: f5392000   edx: 00000000
esi: c21a2d80   edi: ed6778e0   ebp: 00000001   esp: ec8b6de4
ds: 007b   es: 007b   ss: 0068
Process hotplug (pid: 340, threadinfo=ec8b6000 task=ec8b05c0)
Stack: c0141ad5 ec8d3000 c21a2d80 00000001 ec8d3000 ed6778e0 c21a2d80 c21a2e40
       c0141c57 c21a2d80 ed6778e0 00000001 c21a2d80 ed6778e0 ec8d3000 00000010
       00000001 000000d0 c21c9080 0000000c c21a2e08 c21a2d80 c0141e46 c21a2d80
Call Trace:
 [<c0141ad5>] cache_init_objs+0x35/0x56
 [<c0141c57>] cache_grow+0xfb/0x187
 [<c0141e46>] cache_alloc_refill+0x163/0x19c
 [<c0142061>] kmem_cache_alloc+0x67/0x97
 [<c0111671>] pgd_alloc+0x17/0x336
 [<c01199d4>] mm_init+0xd7/0x116
 [<c01199e4>] mm_init+0xe7/0x116
 [<c0119a3d>] mm_alloc+0x2a/0x31
 [<c0162b55>] do_execve+0x82/0x210
 [<c0105d79>] sys_execve+0x2c/0x8e
 [<c010737f>] syscall_call+0x7/0xb
Code: 74 02 66 a5 a8 01 74 01 a4 5e 5b 5e 5f c3 80 3d 04 f7 2e c0 00 75 1c 6a 20
6a 00 ff 74 24 0c e8 ce 37 00 00 83 c4 0c 85 c0 74 08 <0f> 0b 32 01 2f 2b 27 c0
c3 80 3d 04 f7 2e c0 00 75 0d c7 44 24
 <0>Fatal exception: panic in 5 seconds

see more in attachment

Expected results:
the machine boots

Additional info:
The second time you boot the machine with more memory, the machine works.
Comment 1 Daniel Fosselius 2007-07-04 03:20:52 EDT
Created attachment 158501 [details]
whole kernel panic
Comment 3 Chris Lalancette 2008-02-26 21:55:17 EST
This is against the wrong component; the problem here is really that the RHEL-4
PV guest kernel was crashing.  However, that bug was solved in 4.6 by BZ 233543.
 Closing as a dup; if you continue to experience problems, please re-open.

Chris Lalancette

*** This bug has been marked as a duplicate of 233543 ***

Note You need to log in before you can comment on or make changes to this bug.