Bug 246712 - Server X doesn't shut down on shut down / logout.
Server X doesn't shut down on shut down / logout.
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-04 06:49 EDT by markm
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-31 09:33:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/xorg.conf (2.53 KB, text/plain)
2007-07-04 15:20 EDT, markm
no flags Details
/var/log/Xorg.0.log (21.96 KB, text/plain)
2007-07-04 15:21 EDT, markm
no flags Details
/var/log/Xorg.0.log.old (21.96 KB, text/plain)
2007-07-04 15:22 EDT, markm
no flags Details
/var/log/Xorg.20.log (21.78 KB, text/plain)
2007-07-04 15:22 EDT, markm
no flags Details
/var/log/Xorg.20.log.old (22.36 KB, text/plain)
2007-07-04 15:23 EDT, markm
no flags Details
xorg.conf created by X11 (1.44 KB, text/plain)
2007-07-04 15:28 EDT, markm
no flags Details
Xorg.0.log created with fresh xorg.conf (21.82 KB, text/plain)
2007-07-04 15:29 EDT, markm
no flags Details

  None (edit)
Description markm 2007-07-04 06:49:21 EDT
Description of problem:

When I want to logout session or shutdown computer, it doesn't work. Gnome panel
disappears, nautilus closes, but can still see moving mouse - looks like server
X is still working and doesn't want to close. Have to press a few times 'off'
button, then system closes. Very annoying.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.3.0.0-9.fc7 (I have tried also -13.fc8)
xorg-x11-apps-7.1-4.fc7

How reproducible:

always

Steps to Reproduce:
1. login to Gnome session
2. logout or shutdown
3. server X remains running
  
Actual results:

server x remains running

Expected results:

server x closes and computer shows login screen or shuts down

Additional info:

I am using latest nvidia drivers from freshrpms.net repo, but this problem
happens with nv driver, so I think it's not a driver related problem.
Comment 1 Matěj Cepl 2007-07-04 09:52:18 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 markm 2007-07-04 15:20:45 EDT
Created attachment 158536 [details]
/etc/X11/xorg.conf
Comment 3 markm 2007-07-04 15:21:51 EDT
Created attachment 158537 [details]
/var/log/Xorg.0.log
Comment 4 markm 2007-07-04 15:22:16 EDT
Created attachment 158538 [details]
/var/log/Xorg.0.log.old
Comment 5 markm 2007-07-04 15:22:47 EDT
Created attachment 158539 [details]
/var/log/Xorg.20.log
Comment 6 markm 2007-07-04 15:23:03 EDT
Created attachment 158540 [details]
/var/log/Xorg.20.log.old
Comment 7 markm 2007-07-04 15:28:50 EDT
Created attachment 158541 [details]
xorg.conf created by X11

While starting X11 asked me to choose LCD flat panel (resolution was right,
1440x900, but I was able to choose max 800x600, after selecting proper LCD, I
was able to select 1440x900).
Comment 8 markm 2007-07-04 15:29:25 EDT
Created attachment 158542 [details]
Xorg.0.log created with fresh xorg.conf
Comment 9 markm 2007-07-04 15:30:24 EDT
Also, my friend has exactly the same Dell Latitude D620 and he has similar problem.
Comment 10 Adam Jackson 2007-07-27 16:41:19 EDT
All of those logs show runs with the closed-source nvidia driver, which we are
unable to support.  Do you experience this problem with the nv driver?
Comment 11 Matěj Cepl 2007-07-30 09:57:01 EDT
Marek, ajax is too nice to say it as bluntly as I am going to. Unless, you are
able to reproduce this bug with open source driver (most probably nv) in two
weeks, I will have to close this bug as CANTFIX. Usual nVidia blurb follows:

For users who are experiencing problems installing, configuring, or using the
unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
indirect customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and passes them on to
Nvidia engineers for investigation.  Once they've isolated a particular problem,
it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have
experienced the particular problem may be able to assist.  If there is a real
bug occuring, Nvidia will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system releases that they
officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring
technical support may also find the various X.Org, XFree86, and Red Hat mailing
lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo
Comment 12 Matěj Cepl 2007-08-31 09:33:10 EDT
No response from reporter, so continuing as said above. This is closed as
CANTFIX, because we cannot fix binary-only proprietary drivers.

Note You need to log in before you can comment on or make changes to this bug.