Bug 246717 - ypbind occasionally fails to start
ypbind occasionally fails to start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ypbind (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-04 07:41 EDT by Anders Blomdell
Modified: 2008-01-25 06:52 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-25 06:52:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix to problem (931 bytes, patch)
2007-07-04 07:41 EDT, Anders Blomdell
no flags Details | Diff

  None (edit)
Description Anders Blomdell 2007-07-04 07:41:58 EDT
Description of problem:

/etc/rc.d/init.d/ypbind occasionally fails to wait for ypbind server to be
started, and hance executes a 'stop'

Version-Release number of selected component (if applicable):

ypbind-1.19-9.fc7


How reproducible:

Sometimes

Steps to Reproduce:
1. service ypbind start
  
Actual results:

Service sometimes fails to start

Expected results:

Started service...

Additional info:
Comment 1 Anders Blomdell 2007-07-04 07:41:58 EDT
Created attachment 158515 [details]
Fix to problem
Comment 2 Ahmon Dancy 2007-08-17 20:41:40 EDT
This happens to me as well, except that it consistently fails to start.  Here is
part of the issue:

For whatever reason, on my system, "rpcinfo -p" is only showing the portmapper
bindings.   /etc/init.d/ypbind uses "rpcinfo -p" to determine if ypbind started
successfully.  Since ypbind doesn't appear in the output, it concludes that
something is wrong and stops the service.

"rpcinfo -p localhost" shows the full expected information so I've modified my
/etc/init.d/ypbind accordingly.  I don't know if this is a bug in rpcinfo or
what.  Perhaps the fact that I have ipv6 enabled is related? who knows.  At the
very least, I suggest deploying an interim package which uses the "rpcinfo -p
localhost" technique.
Comment 3 Anders Blomdell 2007-11-07 12:23:21 EST
(In reply to comment #2)
> This happens to me as well, except that it consistently fails to start.  Here is
> part of the issue:
> 
> For whatever reason, on my system, "rpcinfo -p" is only showing the portmapper
> bindings.   /etc/init.d/ypbind uses "rpcinfo -p" to determine if ypbind started
> successfully.  Since ypbind doesn't appear in the output, it concludes that
> something is wrong and stops the service.
> 
> "rpcinfo -p localhost" shows the full expected information so I've modified my
> /etc/init.d/ypbind accordingly.  I don't know if this is a bug in rpcinfo or
> what.  Perhaps the fact that I have ipv6 enabled is related? who knows.  At the
> very least, I suggest deploying an interim package which uses the "rpcinfo -p
> localhost" technique.

Does this mean that my fix doesn't work (which relies on ypwhich only)?

Comment 4 Jussi Eloranta 2008-01-16 12:34:24 EST
I have been suffering from this problem for some time now. After applying the
patch to ypbind init script solved the problem !!!! Thanks!


Note You need to log in before you can comment on or make changes to this bug.