Bug 246723 - backport optimistic DAD patch from upstream
backport optimistic DAD patch from upstream
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
high Severity high
: ---
: ---
Assigned To: Neil Horman
Martin Jenner
:
Depends On:
Blocks: 423791 425461
  Show dependency treegraph
 
Reported: 2007-07-04 09:32 EDT by Neil Horman
Modified: 2008-05-21 10:45 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:45:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Quick and dirty fix. Not tested. (1.60 KB, patch)
2008-01-09 13:18 EST, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Neil Horman 2007-07-04 09:32:18 EDT
Description of problem:
ODAD backport as part of ipv6 work
Comment 1 RHEL Product and Program Management 2007-07-04 09:35:46 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Jarod Wilson 2007-12-13 18:51:05 EST
As it turns out, this patch breaks xen... See bug 423791 for details.
Comment 9 Don Zickus 2007-12-14 13:38:23 EST
in 2.6.18-60.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 10 Lon Hohberger 2008-01-09 13:08:36 EST
The patch contained in this bugzilla breaks the kernel->userland rtnetlink API:

https://bugzilla.redhat.com/show_bug.cgi?id=428143
Comment 12 Lon Hohberger 2008-01-09 13:18:44 EST
Created attachment 291177 [details]
Quick and dirty fix.  Not tested.
Comment 13 Lon Hohberger 2008-01-09 13:26:03 EST
Alternatively, providing /usr/include/linux/if_addr.h in the kernel-headers RPM
and possibly doing this in rtnetlink.h may also retain compatibility:

#ifndef __KERNEL__
#include <linux/if_addr.h>
#endif
Comment 14 Neil Horman 2008-01-09 15:25:08 EST
This is being fixed in bz 428143.  Re-closing
Comment 16 Mike Gahagan 2008-04-07 16:59:18 EDT
confirmed fix is in the -88.el5 kernel.
Comment 18 errata-xmlrpc 2008-05-21 10:45:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.