Bug 246726 - use system-install-packages for missing drivers
use system-install-packages for missing drivers
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-07-04 09:52 EDT by Tim Waugh
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.7.70-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-09 09:35:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2007-07-04 09:52:10 EDT
In system-config-printer it would be useful to be able to install a named
package.  When a PPD is installed, it can check to see what executable(s) it
needs, and can map those to package names if not found in the path.

All it can do with that at the moment is present a dialog suggesting that the
user install the relevant package.

It would be nice if it could ask pirut to install the package.
Comment 1 Jeremy Katz 2007-07-04 10:59:41 EDT
Are you already mapping to package name?  If so, does
'/usr/bin/system-install-packages foo' not do what you want?
Comment 2 Tim Waugh 2007-07-04 11:12:59 EDT
Ah, that's exactly what I'm looking for -- thanks.
Comment 3 Tim Waugh 2007-07-04 14:09:37 EDT
..although actually it doesn't work.  It acts as though no arguments were
supplied even though they were.  I think the userhelper stuff is confusing it:

  \_ /usr/bin/system-install-packages pnm2ppa
      \_ /usr/sbin/userhelper -w system-install-packages pnm2ppa
          \_ /usr/bin/python -tt /usr/sbin/system-install-packages pnm2ppa
Comment 4 Jeremy Katz 2007-07-06 16:09:15 EDT
Works fine for me here -- what version of pirut do you have?
Comment 5 Tim Waugh 2007-07-09 08:19:30 EDT
Trying it on FC-6 with pirut-1.2.8-1.fc6 gives that behaviour anyway.

I can't seem to try it on F-8 at the moment because starting
system-config-printer as non-root doesn't display a window. :-/

Trying 'system-install-packages pnm2ppa' as non-root by hand works on F-8 though.
Comment 6 Jeremy Katz 2007-07-09 09:41:38 EDT
Ah, okay.  Yeah, it's F7 and later at the moment as that's what the patch was
provided for and Owen didn't care much about having it released as an FC6 update

Note You need to log in before you can comment on or make changes to this bug.