Bug 246729 - coreutils breaks with unpackaged files when rebuilt under -devel
coreutils breaks with unpackaged files when rebuilt under -devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Paul Nasrat
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-07-04 10:30 EDT by Oliver Falk
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 07:40:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-07-04 10:30:33 EDT
Please have a look:
http://buildsys.zero42.at/koji/getfile?taskID=10163&name=build.log

It happens on alpha and i386, didn't tried another arch.
Comment 1 Tim Waugh 2007-07-04 12:00:24 EDT
This seems to be due to a change in redhat-rpm-config.
Comment 2 Oliver Falk 2007-07-04 12:16:50 EDT
Yup. That could be likely possible :-)
Comment 3 Tim Waugh 2007-07-05 09:38:37 EDT
It's because the 'find' bit in /usr/lib/rpm/find-lang.sh uses 'type -f' instead
of 'type -f -o -type -l'.  The missing files were symbolic links.

I've patched coreutils to work around it for the moment.
Comment 4 Oliver Falk 2007-07-05 09:58:53 EDT
OK. Great. I should have found that myself; But I had no time to do so. :-(
Thx Tim!
Comment 5 Jeff Johnson 2007-07-10 15:35:22 EDT
Heh. find-lang.sh @rpm5.org has added the symlink test so that
CentOS5/RHEL5 coreutils can be rebuilt by non-redhat rpm.
Comment 6 Panu Matilainen 2007-07-11 03:24:09 EDT
Hehheh. It's on rpm.org as well, I just forgot from 4.4.2.1-rc3 but will be in
final. I'll close this one when it lands in rawhide.
Comment 7 Panu Matilainen 2007-07-23 07:40:11 EDT
Fixed in next rawhide build by 4.4.2.1 final.

Note You need to log in before you can comment on or make changes to this bug.