Bug 24673 - pump -d still updates resolv.conf
pump -d still updates resolv.conf
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-22 23:36 EST by Wade Minter
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 09:30:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Minter 2001-01-22 23:36:27 EST
Running beta2 via cable modem (RoadRunner).

According to the manpage, running pump with the -d option should not update
the DNS information in resolv.conf.  Checking pump upon a reboot gives me:

/sbin/pump -d -i eth0

But the /etc/resolv.conf has changed to the default for a RoadRunner lease,
instead of the changes that I made.
Comment 1 Glen Foster 2001-01-23 12:44:03 EST
This defect is considered MUST-FIX for Florence Release-Candidate #1
Comment 2 Erik Troan 2001-02-01 18:56:51 EST
This works fine for me -- can you let me know exactly what you're seeing, and
how pump is getting run.
Comment 3 David Sainty 2001-02-13 12:16:43 EST
I also just checked pump operation with pump-0.8.7-1. "pump -s -i eth0" on a
system with working interface and valid lease wiped out my /etc/resolv.conf.


Comment 4 David Sainty 2001-02-13 16:30:56 EST
This is very interesting. The problem is that pump runs as a background daemon.
Once it is first started on an interface, it will remain running (by default) as
long as the interface remains up. It does this, so it can do lease renewals, etc.

When pump is first started, it accepts command line parameters, as well as
settings from the pump config file (/etc/pump.conf unless set with -c). If you
enter -d on the command line when you first start pump for an interface, -d
_DOES_ work. It works so well that any subsequent command-line initiated pump's
(e.g. a subsequent "pump -i eth0") will also not touch the resolv.conf file.

The reverse is also true. I start pump without -d as a parameter on an
interface, e.g. eth0. Subsequent "pump -d -i eth0" will cause pump to do its
thing, but the -d option will have no effect.

Summarised, the "overrides" options on the command line only have any effect if
specified for the first pump instance on a given interface. Why? If we specify
-d for example on a subsequent command line, it gets parsed and overrides->flags
is set to 1. When we write to the control socket cont, we do not pass
overrides->flags at all. On the receiving end, in runDaemon, we refer to
overrides->flags, however this is using the overrides that was passed to the
function.

This needs to be cleaned up. Reality doesn't match the man page and command
syntax at the moment.
Comment 5 Erik Troan 2001-02-23 13:23:14 EST
I'll try and do this post-florence
Comment 6 Elliot Lee 2001-08-08 00:29:15 EDT
Given that dhcpcd replaced pump in rawhide, and that the use case seems very 
esoteric, just going to wontfix this. Disagreement welcome.

Apologies for the unresponsiveness of the previous pump packager...

Note You need to log in before you can comment on or make changes to this bug.