Bug 246770 - Requires(post)
Requires(post)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rogue (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Wart
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-04 15:06 EDT by Denise Dumas
Modified: 2008-12-24 13:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-24 07:56:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2007-07-04 15:06:50 EDT
Description of problem:

You should "Require(post): coreutils" if you use "touch" in
the post script.

regards,

Florian La Roche



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Peter Gordon 2007-07-12 04:17:24 EDT
Do we really need to?

coreutils is part of the guaranteed minimal build-root (see
Packaging/FullExceptionList on the wiki); and it's also guaranteed to be
installed on all  installations of Fedora proper since it's noted as "mandatory"
in the comps files. 

Thanks.
Comment 2 Florian La Roche 2007-07-12 04:27:06 EDT
If you install a new machine and have this rpm included, there is no way
for the install tools to know if coreutils needs to be installed prior to
this rpm, so this dependency needs to be added.

regards,

Florian La Roche
Comment 3 Wart 2007-07-12 10:56:19 EDT
I don't disagree with this logic, but I'd like to see this resolved in the
context of the icon cache packaging guidelines[1] before making the change to
this package and others.

[1]http://fedoraproject.org/wiki/Packaging/ScriptletSnippets
Comment 5 Bug Zapper 2008-05-13 23:01:26 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Fedora Update System 2008-12-18 22:33:44 EST
rogue-5.4.5-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/rogue-5.4.5-3.fc9
Comment 7 Fedora Update System 2008-12-21 03:40:52 EST
rogue-5.4.5-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update rogue'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11485
Comment 8 Fedora Update System 2008-12-24 07:56:21 EST
rogue-5.4.5-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-12-24 13:38:00 EST
rogue-5.4.5-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.