Bug 246784 - EXA Performance regression from FC6 to F7 affecting Firefox
EXA Performance regression from FC6 to F7 affecting Firefox
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Depends On:
  Show dependency treegraph
Reported: 2007-07-04 15:39 EDT by Mark Schreiber
Modified: 2008-06-16 21:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-16 21:47:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
xorg log from fedora 7's xorg running with xaa acceleration (4.47 KB, text/plain)
2007-07-04 15:39 EDT, Mark Schreiber
no flags Details
xorg log for Fedora 7's xorg running with EXA enabled (4.47 KB, text/plain)
2007-07-04 15:40 EDT, Mark Schreiber
no flags Details
xorg.conf that produces slowdown in F7, but not in FC6 (3.85 KB, application/octet-stream)
2007-07-04 15:41 EDT, Mark Schreiber
no flags Details

  None (edit)
Description Mark Schreiber 2007-07-04 15:39:53 EDT
Description of problem:
A number of applications exhibit noticeably worse refresh performance when EXA
is enabled in Fedora 7, to the point that the applications are frustrating to
use.  I am using a Radeon 9250 -- I'm not certain whether this is specific to
the ATI driver or to the Xorg package as a whole.  This is a regression from
Fedora Core 6, where EXA worked fine.  Fedora 7 with Fedora Core 6's xorg
packages does not exhibit the problem.

It is particularly noticeable in Firefox.  Open two Firefox windows, each
showing http://www.redhat.com/.  Switching between them is essentially
instantaneous on my 2.4GHz P4 under FC6 EXA or XAA or under F7 XAA.  It takes
1-2 seconds to switch between them under F7 EXA, and xorg CPU usage remains at
100% for about three seconds after the window switch.  Dragging any window over
the Firefox window results in extremely jerky movement and long trails over the

Unfortunately, I do not have a better way of exhibiting the problem -- all
x11perf benchmarks that I've tried show F7 EXA running more quickly than F7 XAA.

Version-Release number of selected component (if applicable):

exhibit the problem.  Using the base FC6 xorg (xorg-x11-drv-ati-6.6.2-4.fc6,

How reproducible:
Run Firefox with EXA enabled.  Try switching between windows showing
http://www.redhat.com/ under EXA.  Observe time taken.

Steps to Reproduce:
1. Add 'Option "AccelMethod" "EXA" to the Device section of xorg.conf.
2. Start xorg.
3. Open two overlapping Firefox windows displaying http://www.redhat.com/
4. Switch between the two.  Observe time required to switch and complete redraw.
Actual results:
Very sluggish performance

Expected results:
Performance at least comparable with XAA in same release or EXA performance in
Fedora Core 6.

Additional info:
I am attaching the xorg logs for EXA and XAA execution -- however, the only
differences between the two are timestamps and a few memory addresses.  I am
also attaching an xorg.conf file that produces the problem under FC7, does not
produce the problem under FC6, and does not produce the problem under FC7 if the
"AccelMethod" line is commented out.
Comment 1 Mark Schreiber 2007-07-04 15:39:53 EDT
Created attachment 158544 [details]
xorg log from fedora 7's xorg running with xaa acceleration
Comment 2 Mark Schreiber 2007-07-04 15:40:56 EDT
Created attachment 158545 [details]
xorg log for Fedora 7's xorg running with EXA enabled
Comment 3 Mark Schreiber 2007-07-04 15:41:51 EDT
Created attachment 158546 [details]
xorg.conf that produces slowdown in F7, but not in FC6
Comment 4 Bug Zapper 2008-05-14 09:24:40 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2008-06-16 21:47:32 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.