Bug 246787 - Xmms installs via yum/pirut but does not install dependent packages
Xmms installs via yum/pirut but does not install dependent packages
Status: CLOSED DUPLICATE of bug 242368
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-04 16:35 EDT by Brent Goodrick
Modified: 2008-03-16 20:35 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-16 20:35:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
More detailed report showing specific packages and versions, and general whining. (8.67 KB, text/plain)
2007-07-04 16:35 EDT, Brent Goodrick
no flags Details

  None (edit)
Description Brent Goodrick 2007-07-04 16:35:39 EDT
I used pirut from Fedora 7 x86_64 to install xmms. I did so, and then when
executing, I get an error about a missing shared library:

bash-3.2$ xmms
/usr/libexec/xmms: error while loading shared libraries: libxmms.so.1: cannot
open shared object file: No such file or directory

That surprised me since that is definitely a dependency that should have been
handled by the yum metadata?

At this point, I looked for what was installed:

bash-3.2$ rpm -q -a | grep -i xmms
xmms-1.2.10-36.fc7
bash-3.2$ rpm -q --info xmms
Name        : xmms                         Relocations: (not relocatable)
Version     : 1.2.10                            Vendor: Fedora Project
Release     : 36.fc7                        Build Date: Fri 13 Apr 2007 06:28:15
PM EDT
Install Date: Wed 04 Jul 2007 12:14:05 PM EDT      Build Host:
xenbuilder1.fedora.redhat.com
Group       : Applications/Multimedia       Source RPM: xmms-1.2.10-36.fc7.src.rpm
Size        : 4759686                          License: GPL
Signature   : DSA/SHA1, Mon 21 May 2007 02:54:10 PM EDT, Key ID b44269d04f2a6fd2
Packager    : Fedora Project <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.xmms.org/
Summary     : The X MultiMedia System, a media player
Description :
XMMS is a multimedia (Ogg Vorbis, CDs) player for the X Window System
with an interface similar to Winamp's.  XMMS supports playlists and
streaming content and has a configurable interface.

Then examined the dependencies on the xmms package:

bash-3.2$ rpm -q --requires xmms

/bin/sh  
/bin/sh  
/bin/sh  
/usr/share/desktop-menu-patches/redhat-audio-player.desktop  
desktop-file-utils >= 0.9
desktop-file-utils >= 0.9
libICE.so.6()(64bit)  
libSM.so.6()(64bit)  
libX11.so.6()(64bit)  
libXext.so.6()(64bit)  
libXi.so.6()(64bit)  
libXxf86vm.so.1()(64bit)  
libc.so.6()(64bit)  
libc.so.6(GLIBC_2.2.5)(64bit)  
libc.so.6(GLIBC_2.3)(64bit)  
libc.so.6(GLIBC_2.3.2)(64bit)  
libc.so.6(GLIBC_2.3.4)(64bit)  
libc.so.6(GLIBC_2.4)(64bit)  
libdl.so.2()(64bit)  
libdl.so.2(GLIBC_2.2.5)(64bit)  
libgdk-1.2.so.0()(64bit)  
libglib-1.2.so.0()(64bit)  
libgmodule-1.2.so.0()(64bit)  
libgthread-1.2.so.0()(64bit)  
libgtk-1.2.so.0()(64bit)  
libm.so.6()(64bit)  
libm.so.6(GLIBC_2.2.5)(64bit)  
libpthread.so.0()(64bit)  
libpthread.so.0(GLIBC_2.2.5)(64bit)  
libxmms.so.1()(64bit)  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)  
unzip  

I then thought that I could simply work around it from reading from posts on
http://www.fedoraforum.org for prior Fedora releases, not F7, by simply
installing xmms-libs, which I did.  rpm now shows:

bash-3.2$ rpm -q xmms-libs
xmms-libs-1.2.10-36.fc7
bash-3.2$ rpm -q --info xmms-libs
Name        : xmms-libs                    Relocations: (not relocatable)
Version     : 1.2.10                            Vendor: Fedora Project
Release     : 36.fc7                        Build Date: Fri 13 Apr 2007 06:28:15
PM EDT
Install Date: Wed 04 Jul 2007 12:41:44 PM EDT      Build Host:
xenbuilder1.fedora.redhat.com
Group       : System Environment/Libraries   Source RPM: xmms-1.2.10-36.fc7.src.rpm
Size        : 685608                           License: GPL
Signature   : DSA/SHA1, Mon 21 May 2007 02:54:19 PM EDT, Key ID b44269d04f2a6fd2
Packager    : Fedora Project <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.xmms.org/
Summary     : XMMS engine and core plugins
Description :
The X MultiMedia System player engine and core plugins.
bash-3.2$ rpm -q -l xmms-libs
/usr/lib64/libxmms.so.1
/usr/lib64/libxmms.so.1.3.1
/usr/lib64/xmms
/usr/lib64/xmms/Effect
/usr/lib64/xmms/Effect/libecho.so
/usr/lib64/xmms/Effect/libstereo.so
/usr/lib64/xmms/Effect/libvoice.so
/usr/lib64/xmms/General
/usr/lib64/xmms/General/libir.so
/usr/lib64/xmms/General/libjoy.so
/usr/lib64/xmms/General/libsong_change.so
/usr/lib64/xmms/Input
/usr/lib64/xmms/Input/libcdaudio.so
/usr/lib64/xmms/Input/libmikmod.so
/usr/lib64/xmms/Input/librh_mp3.so
/usr/lib64/xmms/Input/libtonegen.so
/usr/lib64/xmms/Input/libvorbis.so
/usr/lib64/xmms/Input/libwav.so
/usr/lib64/xmms/Output
/usr/lib64/xmms/Output/libALSA.so
/usr/lib64/xmms/Output/libOSS.so
/usr/lib64/xmms/Output/libdisk_writer.so
/usr/lib64/xmms/Visualization
/usr/lib64/xmms/Visualization/libbscope.so
/usr/lib64/xmms/Visualization/libogl_spectrum.so
/usr/lib64/xmms/Visualization/libsanalyzer.so
/usr/share/doc/xmms-libs-1.2.10
/usr/share/doc/xmms-libs-1.2.10/COPYING
bash-3.2$ file /usr/lib64/libxmms.so.1
/usr/lib64/libxmms.so.1: symbolic link to `libxmms.so.1.3.1'
bash-3.2$ file /usr/lib64/libxmms.so.1.3.1
/usr/lib64/libxmms.so.1.3.1: ELF 64-bit LSB shared object, x86-64, version 1
(SYSV), stripped
bash-3.2$ which xmms
/usr/bin/xmms
bash-3.2$ ldd /usr/bin/xmms
	not a dynamic executable
bash-3.2$ file /usr/bin/xmms
/usr/bin/xmms: Bourne shell script text executable
bash-3.2$ cat /usr/bin/xmms
#!/bin/sh

# https://bugzilla.redhat.com/213172
if [ -z "$XLIB_SKIP_ARGB_VISUALS" ] ; then
    exec env XLIB_SKIP_ARGB_VISUALS=1 /usr/libexec/xmms "$@"
else
    exec /usr/libexec/xmms "$@"
fi
bash-3.2$ file /usr/libexec/xmms
/usr/libexec/xmms: ELF 64-bit LSB executable, x86-64, version 1 (SYSV),
dynamically linked (uses shared libs), for GNU/Linux 2.6.9, stripped
bash-3.2$ ldd /usr/libexec/xmms
	libSM.so.6 => /usr/lib64/libSM.so.6 (0x0000003afcc00000)
	libICE.so.6 => /usr/lib64/libICE.so.6 (0x0000003afc000000)
	libXxf86vm.so.1 => /usr/lib64/libXxf86vm.so.1 (0x0000003b07c00000)
	libxmms.so.1 => /usr/lib64/libxmms.so.1 (0x00002aaaaaace000)
	libgtk-1.2.so.0 => not found
	libgdk-1.2.so.0 => not found
	libgmodule-1.2.so.0 => not found
	libgthread-1.2.so.0 => not found
	libglib-1.2.so.0 => not found
	libdl.so.2 => /lib64/libdl.so.2 (0x0000003af3600000)
	libXi.so.6 => /usr/lib64/libXi.so.6 (0x0000003af6e00000)
	libXext.so.6 => /usr/lib64/libXext.so.6 (0x0000003af5600000)
	libX11.so.6 => /usr/lib64/libX11.so.6 (0x0000003af4e00000)
	libm.so.6 => /lib64/libm.so.6 (0x0000003af3200000)
	libc.so.6 => /lib64/libc.so.6 (0x0000003af2e00000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003af4200000)
	/lib64/ld-linux-x86-64.so.2 (0x0000003af1e00000)
	libgtk-1.2.so.0 => not found
	libgdk-1.2.so.0 => not found
	libgmodule-1.2.so.0 => not found
	libgthread-1.2.so.0 => not found
	libglib-1.2.so.0 => not found
	libXau.so.6 => /usr/lib64/libXau.so.6 (0x0000003af5200000)
	libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x0000003af4a00000)

Uh oh, a lot of things are not found there.  But, perhaps the libgtk shared
library is stored mysteriously somewhere else on the system, but that is not the
case:

bash-3.2$ xmms
/usr/libexec/xmms: error while loading shared libraries: libgtk-1.2.so.0: cannot
open shared object file: No such file or directory

So, I then installed gtk+

bash-3.2$ rpm -q gtk+
gtk+-1.2.10-57.fc7

And invoked xmms again, and got a different runtime link error:

bash-3.2$ xmms
/usr/libexec/xmms: error while loading shared libraries: libgmodule-1.2.so.0:
cannot open shared object file: No such file or directory

The glib2 package is installed already, but glib2 does not supply
libgmodule-1.2.so.0.  I found that in the glib package, which I installed:

bash-3.2$ rpm -q -l glib-1.2.10-26.fc7
/usr/lib64/libglib-1.2.so.0
/usr/lib64/libglib-1.2.so.0.0.10
/usr/lib64/libgmodule-1.2.so.0
/usr/lib64/libgmodule-1.2.so.0.0.10
/usr/lib64/libgthread-1.2.so.0
/usr/lib64/libgthread-1.2.so.0.0.10
/usr/share/doc/glib-1.2.10
/usr/share/doc/glib-1.2.10/AUTHORS
/usr/share/doc/glib-1.2.10/COPYING
/usr/share/doc/glib-1.2.10/ChangeLog
/usr/share/doc/glib-1.2.10/NEWS
/usr/share/doc/glib-1.2.10/README
b

Summary: all of the packages that I had to download manually should have been
downloaded and installed automatically via the dependency metadata for the
top-most package, xmms.

I marked this high since this is a regression from FC6 where this seemed to work
flawlessly.

Things in F7 are working very, very well other than this issue. Keep up the good
work!

Brent
Comment 1 Brent Goodrick 2007-07-04 16:35:40 EDT
Created attachment 158549 [details]
More detailed report showing specific packages and versions, and general whining.
Comment 2 Brent Goodrick 2007-07-04 16:40:30 EDT
Oops, I ended up pasting the full report in the main window instead of the
summary.  And, to add embarrasing insult to injury, there is no way for me to go
back and fix my mistake.  grrr.

Well, here is the summary:

I used pirut from Fedora 7 x86_64 to install xmms (the x86_64 form of course). I
did so, and then when executing xmms, I get an error about a missing shared library:

bash-3.2$ xmms
/usr/libexec/xmms: error while loading shared libraries: libxmms.so.1: cannot
open shared object file: No such file or directory

That surprised me since that is definitely a dependency that should have been
handled by the yum metadata.

I then tracked down all of the packages, one by one, that I needed to install. 
In that process, I saw various runtime linker errors, which I resolved manually
one by one:

/usr/libexec/xmms: error while loading shared libraries: libxmms.so.1: cannot
open shared object file: No such file or directory
/usr/libexec/xmms: error while loading shared libraries: libgtk-1.2.so.0: cannot
open shared object file: No such file or directory
/usr/libexec/xmms: error while loading shared libraries: libgmodule-1.2.so.0:
cannot open shared object file: No such file or directory

In summary, the dependency metadata for the xmms package needs to be updated to
include these dependencies:

xmms-libs
gtk+
glib
mikmod

Find attached to this bug a more lengthy report text file for your reference.


Comment 3 Axel Thimm 2007-07-04 17:05:06 EDT
How did I and so many other people get on the initialcc of this bug? Did Brent
put us there, or is this a bugzilla core/extras merge bug?
Comment 4 Brent Goodrick 2007-07-04 18:49:06 EDT
(In reply to comment #3)
> How did I and so many other people get on the initialcc of this bug? Did Brent
> put us there, or is this a bugzilla core/extras merge bug?

My appologies. I used the "clone bug" feature, and apparently, that may also
have cloned the CC list resulting in the extra spam.  I will try my best to be
more careful next time to remove the CC list during cloning.  Let me know how I
should edit the CC list down to the appropriate list.

Brent
Comment 5 Michael Schwendt 2008-03-14 18:39:11 EDT
Please assign this to the proper package (pirut or yum), because
in the xmms* packages the dependencies do exist in form of
library SONAME requirements (you even showed that), and it is
yum's responsibility to resolve them and install the packages
that provide those libraries.

It is embarrassing that this ticket was not reassigned
several months ago when Fedora 7 was fresher.

> In summary, the dependency metadata for the xmms package
> needs to be updated to include these dependencies:

No.
Comment 6 Michael Schwendt 2008-03-16 20:35:28 EDT

*** This bug has been marked as a duplicate of 242368 ***

Note You need to log in before you can comment on or make changes to this bug.