Bug 246811 - cronolog package can't handle files bigger than 2GB when running in a 32bit OS
Summary: cronolog package can't handle files bigger than 2GB when running in a 32bit OS
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cronolog   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: jafo-redhat
QA Contact: Fedora Extras Quality Assurance
URL: http://cronolog.org/patches/index.html
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-05 05:46 UTC by Arenas Belon, Carlo Marcelo
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-06 01:46:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
use O_LARGEFILE for basic LFS support in 32bit linux as currently being used in gentoo (820 bytes, patch)
2007-07-05 05:46 UTC, Arenas Belon, Carlo Marcelo
no flags Details | Diff

Description Arenas Belon, Carlo Marcelo 2007-07-05 05:46:30 UTC
Description of problem:
when running in a 32bit architecture (i386/i686 for example) cronolog won't be
able to write to a file that is bigger than 2GB and will refuse to start if the
log is that large as well, resulting in missing log data and reliability problems

Version-Release number of selected component (if applicable):
1.6.2-4

How reproducible:
always

Steps to Reproduce:
1. configure an application to use cronolog to print (by piping to it)
2. let it run until the logs grows bigger than 2GB
3. restart application
  
Actual results:
application won't restart because cronolog would fail to start

Expected results:
application will start and keep writting to its log through cronolog

Additional info:
a patch is provided from upstream as shown in the URL, with the root cause being
that LFS support wasn't enabled in cronolog latest released version

Comment 1 Arenas Belon, Carlo Marcelo 2007-07-05 05:46:30 UTC
Created attachment 158573 [details]
use O_LARGEFILE for basic LFS support in 32bit linux as currently being used in gentoo

Comment 2 Sean Reifschneider 2007-07-06 01:46:00 UTC
Thanks for the patch, I've committed it and it will be included in release "5"
as soon as it gets built and pushed out for F7.

Sean


Note You need to log in before you can comment on or make changes to this bug.