Bug 246817 - dmraid forced upon install
dmraid forced upon install
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-05 03:49 EDT by Sean Bruno
Modified: 2008-06-16 21:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:47:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg of livecd boot (47.42 KB, text/plain)
2007-07-05 03:49 EDT, Sean Bruno
no flags Details
lspci -vv output on target machine (20.26 KB, text/plain)
2007-07-05 03:49 EDT, Sean Bruno
no flags Details
dmesg output of kernel boot with nodmraid and nompath options (47.38 KB, text/plain)
2007-07-06 22:07 EDT, Sean Bruno
no flags Details

  None (edit)
Description Sean Bruno 2007-07-05 03:49:11 EDT
Description of problem:
Installer insists on using /dev/mapper/mapper0 to use as the install target
while there are no dmraid devices configured.

Version-Release number of selected component (if applicable):
F7

How reproducible:
Every time

Steps to Reproduce:
1.  Using a K8N-DL mobo and two SATA HD's connected to the Nvidia CK804 SATA
controller, attempt to install.
2.  During the install process, you will be prompted multiple times to
initialize /dev/mapper/mapper0 even though no dmraid devices are enabled.
3.  Installer will not allow you to disable dmraid device.
4.  Installer will fail when attempting to partition non-existent device.

  
Actual results:
Installer fails.

Expected results:
Installer should either allow you to disable the dmraid option under the button
"advanced storage configuration" or just allow me to use /dev/sda and /dev/sdb
normally.

Additional info:
Using the kernel option 'nodmraid' has no effect on this bug, which may be
another bug alltogether.
Comment 1 Sean Bruno 2007-07-05 03:49:11 EDT
Created attachment 158574 [details]
dmesg of livecd boot
Comment 2 Sean Bruno 2007-07-05 03:49:48 EDT
Created attachment 158575 [details]
lspci -vv output on target machine
Comment 3 Sean Bruno 2007-07-05 03:51:14 EDT
The installer from the live CD installation doesn't allow me to select /dev/sda
and /dev/sdb even though they are present in the system.

Starting dmraid shows that no disks are present:
[root@localhost ~]# dmraid -a y
No RAID disks
Comment 4 Sean Bruno 2007-07-05 03:53:19 EDT
Disconnecting /dev/sdb from my system allows the install to proceed normally on
/dev/sda.  However the whole point of this exercise was to install a system with
S/W raid 1.
Comment 5 Sean Bruno 2007-07-06 01:21:30 EDT
I have now tested the three SATA fake-raid controllers at my disposal.  I have a
ck804 and SiL 3118 onboard.  I also tested a 1210SA that I had lying around. 
All three fail on filesystem creation and cause the installer to exit.

They all fail slightly differently and I possibly need to open a new ticket on
each controller.  At this point, I cannot use the raid controllers that I have
at my disposal with Fedora 7 nor can I install in a s/w raid configuration as
the /dev/mapper s/w forces itself upon me without giving me a choice.

In addition, when I install the system with one hard disk, I can't create a
broken raid 1 so that I could later add a second drive(the installer tells me
that a RAID 1 needs two devices and won't let me override it).

Sorry if this is a bit of a rambling diatribe, I would love to debug this
further if possible.  How should I begin to debug?
Comment 6 Jeremy Katz 2007-07-06 08:52:31 EDT
If you add 'nodmraid' to your boot command line (or run liveinst --nodmraid),
then you should be able to override the use of dmraid.  Does that not work?
Comment 7 Sean Bruno 2007-07-06 14:32:50 EDT
the nodmraid option on the kernel command line didn't help when I last tried it,
i.e. the installer still assumed that I wanted to use /dev/mapper stuff.

Someone else suggested that I try  "nompath" to get around this issue.

I didn't know that the liveinst app had command line arguments, what other
options are there?
Comment 8 Sean Bruno 2007-07-06 21:50:19 EDT
The liveinstaller seems to ignore the --nodmraid option on my machine:

Just to be certain that I did blow away the superblock:

[root@localhost ~]# dmraid -a y
No RAID disks


I also tried --nompath as suggested on the mailing list, and it failed as well.
Comment 9 Sean Bruno 2007-07-06 22:07:39 EDT
Created attachment 158706 [details]
dmesg output of kernel boot with nodmraid and nompath options
Comment 10 Bug Zapper 2008-05-14 09:24:48 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2008-06-16 21:47:39 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.