Bug 246829 - psacct initscript is always returning error code 0
Summary: psacct initscript is always returning error code 0
Status: CLOSED DUPLICATE of bug 247034
Alias: None
Product: Fedora
Classification: Fedora
Component: psacct (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-05 10:39 UTC by Terje Rosten
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-12 12:29:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix error codes from initscript (997 bytes, text/plain)
2007-07-05 10:39 UTC, Terje Rosten
no flags Details

Description Terje Rosten 2007-07-05 10:39:53 UTC
Description of problem:

The psacct initscript is returning error code 0 no matter what.
Even when is the status, while psacct is not running is returning 0.

In additional the initscript don't check error code from /sbin/accton.

Version-Release number of selected component (if applicable):

psacct-6.3.2-44.fc7

How reproducible:

Stop psacct:

/etc/init.d/psacct stop

and then issue the status command:

/etc/init.d/psacct status >/dev/null 2>&1 ; echo $?

As psacct is stopped this should return 3, however returns 0

A patch to fix these problems is attached.

Comment 1 Terje Rosten 2007-07-05 10:39:53 UTC
Created attachment 158578 [details]
Patch to fix error codes from initscript

Comment 2 Ivana Varekova 2007-07-12 12:29:17 UTC

*** This bug has been marked as a duplicate of 247034 ***


Note You need to log in before you can comment on or make changes to this bug.