Bug 24683 - core dump when running java
Summary: core dump when running java
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-23 13:21 UTC by david.oh
Modified: 2016-11-24 14:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-24 13:01:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description david.oh 2001-01-23 13:21:40 UTC
seeing a segmentation fault and core dump when
trying to run java (jdk1.2.2) on RHat 7.0

Comment 1 Jakub Jelinek 2001-01-23 13:33:05 UTC
Do you have latest glibc errata (glibc-2.2-12 at this point) installed?

Comment 2 david.oh 2001-01-24 05:22:06 UTC
I am unsure if I am executing the correct commands, because RPM keeps
bouncing me out....

1) // attempt to install glibc-common before glib-2.2-12
   // as follows
   rpm -ivh glibc-common*
error: failed dependencies:
        glibc < 2.2-12 conflicts with glibc-common-2.2-12
2) // list all rpm entries on my RHAT 7 machine
# rpm -qa | grep glibc
glibc-2.1.92-14
glibc-devel-2.1.92-14

3)  // since rpm identifies glibc-common-2.2-12 as a depency, lets
    to install glibc-common-2.2-12 
rpm -ivh glibc-common-2.2-12.i386.rpm
error: failed dependencies:
        glibc < 2.2-12 conflicts with glibc-common-2.2-12

any help would be appreciated


Comment 3 Jakub Jelinek 2001-01-24 09:47:18 UTC
You have to upgrade glibc and glibc-common at once, such as in:
rpm -Uvh glibc-2.2-12.i686.rpm glibc-common-2.2-12.i386.rpm
the rest can be done with rpm -F, one by one, whatever you want.

Comment 4 david.oh 2001-01-24 13:01:27 UTC
how does this affect the workaround as described in bug # 18391
I have included the document for your perusal
http://ftp.valinux.com/pub/support/hjl/glibc/sdk/2.1/README.Oracle8i


Comment 5 david.oh 2001-01-27 14:45:50 UTC
problem solved 
the new rpm works and regression tests OK the new library


Note You need to log in before you can comment on or make changes to this bug.